Difficulty Compiling NWChem on Cray - Numerous Undefined References

From NWChem

You are viewing a single post from the thread title above
Jump to: navigation, search

Click here for full thread
Just Got Here
Threads 1
Posts 3
Thank you
Dear Edoapra
I came back from a conference to find this kind reply, thank you.
Incorporating USE_64to32=y in the make options appears to have fixed the compile problem.
Exact procedure for future me, and any other similar unfortunates:

export NWCHEM_TOP=~/nwchem-6.5   
export NWCHEM_TARGET=LINUX64
export NWCHEM_MODULES="all"
export USE_MPI=y
export USE_MPIF=y
export USE_MPIF4=y
export USE_SCALAPACK=y
export USE_64to32=y
export LIBMPI=" "

module swap PrgEnv-cray PrgEnv-gnu
module load craype-hugepages64M
module load dmapp

cd $NWCHEM_TOP/src/tools
wget https://github.com/ryanolson/ga/archive/cray.zip -O cray.zip
unzip cray.zip
export GA_DIR=ga-cray
make FC=ftn 
module load dmapp

export ARMCI_NETWORK=DMAPP
export USE_SCALAPACK=y
export SCALAPACK="-lsci_gnu"
export SCALAPACK_LIB="-lsci_gnu"
export BLASOPT="-lsci_gnu"
export BLAS_LIB="-lsci_gnu"
export LAPACK_LIB="-lsci_gnu"
export USE_64to32=y

export HUGETLB_MORECORE=yes
export HUGETLB_DEFAULT_PAGE_SIZE=8M
export UGNI_CDM_MDD_DEDICATED=2
cd $NWCHEM_TOP/src
make nwchem_config FC=ftn GA_DIR=ga-cray 

export USE_64TO32=y
cd 64to32blas
make FC=ftn

cd..
make FC=ftn GA_DIR=ga-cray USE_64TO32=y link


Who's here now Members 0 Guests 0 Bots/Crawler 0


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC