NWchem6.6 on OpenSUSE compile fails: ld: cannot find -lga -larmci

From NWChem

You are viewing a single post from the thread title above
Jump to: navigation, search

Click here for full thread
Just Got Here
Threads 1
Posts 2
Hello evergyone,

when I complile NWchem6.6 on OpenSUSE.version.13.2, errors come like this:
==============================================
make nwchem.o stubs.o
make[1]: Entering directory '/home/hhao/mathlib/nwchem-6.6/src'
ifort -i8 -align -fpp -vec-report6 -fimf-arch-consistency=true -finline-limit=250 -O2 -g -fp-model source -I. -I/home/hhao/mathlib/nwchem-6.6/src/include -I/home/hhao/mathlib/nwchem-6.6/src/tools/install/include -DEXT_INT -DLINUX -DLINUX64 -DIFCV8 -DIFCLINUX -DNOIO -DEAFHACK -DPARALLEL_DIAG -DCOMPILATION_DATE="'`date +%a_%b_%d_%H:%M:%S_%Y`'" -DCOMPILATION_DIR="'/home/hhao/mathlib/nwchem-6.6'" -DNWCHEM_BRANCH="'6.6'" -c -o nwchem.o nwchem.F
nwchem.F(651): (col. 15) remark: BLOCK WAS VECTORIZED.
nwchem.F(654): (col. 15) remark: BLOCK WAS VECTORIZED.
nwchem.F(661): (col. 16) remark: BLOCK WAS VECTORIZED.
nwchem.F(663): (col. 16) remark: BLOCK WAS VECTORIZED.
nwchem.F(666): (col. 13) remark: loop was not vectorized: vectorization possible but seems inefficient.
nwchem.F(666): (col. 13) remark: BLOCK WAS VECTORIZED.
nwchem.F(275): (col. 11) remark: loop was not vectorized: nonstandard loop is not a vectorization candidate.
nwchem.F(460): (col. 10) remark: loop was not vectorized: vectorization possible but seems inefficient.
nwchem.F(463): (col. 11) remark: loop was not vectorized: vectorization possible but seems inefficient.
nwchem.F(465): (col. 11) remark: loop was not vectorized: vectorization possible but seems inefficient.
nwchem.F(651): (col. 15) remark: BLOCK WAS VECTORIZED.
nwchem.F(654): (col. 15) remark: BLOCK WAS VECTORIZED.
nwchem.F(661): (col. 16) remark: BLOCK WAS VECTORIZED.
nwchem.F(663): (col. 16) remark: BLOCK WAS VECTORIZED.
nwchem.F(666): (col. 13) remark: loop was not vectorized: vectorization possible but seems inefficient.
nwchem.F(666): (col. 13) remark: BLOCK WAS VECTORIZED.
nwchem.F(460): (col. 10) remark: loop was not vectorized: vectorization possible but seems inefficient.
nwchem.F(463): (col. 11) remark: loop was not vectorized: vectorization possible but seems inefficient.
nwchem.F(465): (col. 11) remark: loop was not vectorized: vectorization possible but seems inefficient.
ifort -i8 -align -fpp -vec-report6 -fimf-arch-consistency=true -finline-limit=250 -O2 -g -fp-model source -I. -I/home/hhao/mathlib/nwchem-6.6/src/include -I/home/hhao/mathlib/nwchem-6.6/src/tools/install/include -DEXT_INT -DLINUX -DLINUX64 -DIFCV8 -DIFCLINUX -DNOIO -DEAFHACK -DPARALLEL_DIAG -DCOMPILATION_DATE="'`date +%a_%b_%d_%H:%M:%S_%Y`'" -DCOMPILATION_DIR="'/home/hhao/mathlib/nwchem-6.6'" -DNWCHEM_BRANCH="'6.6'" -c -o stubs.o stubs.F
make[1]: Leaving directory '/home/hhao/mathlib/nwchem-6.6/src'
ifort -i8 -align -fpp -vec-report6 -fimf-arch-consistency=true -finline-limit=250 -O2 -g -fp-model source -L/home/hhao/mathlib/nwchem-6.6/lib/LINUX64 -L/home/hhao/mathlib/nwchem-6.6/src/tools/install/lib -o /home/hhao/mathlib/nwchem-6.6/bin/LINUX64/nwchem nwchem.o stubs.o -lnwctask -lccsd -lmcscf -lselci -lmp2 -lmoints -lstepper -ldriver -loptim -lnwdft -lgradients -lcphf -lesp -lddscf -lguess -lhessian -lvib -lnwcutil -lrimp2 -lproperty -lsolvation -lnwints -ldplot -lvscf -letrans -ltce -lbq -lcons -lnwcutil -lga -larmci -lpeigs -lperfm -lcons -lbq -lnwcutil -l64to32 -L/opt/intel/mkl/lib/intel64/ -lmkl_intel_lp64 -lmkl_sequential -lmkl_core -lpthread -lm -lnwclapack -lnwcblas -L/opt/intel/impi/4.1.0.024/intel64/lib -ldl -lmpi -lmpigf -lmpigi -lrt -lpthread
ld: cannot find -lga
ld: cannot find -larmci
GNUmakefile:33: recipe for target 'all' failed
make: *** [all] Error 1
===========================

The environment variables were set as:
===========================
export NWCHEM_TOP=/home/hhao/mathlib/nwchem-6.6
export NWCHEM_TARGET=LINUX64
export NWCHEM_MODULES="qm"
export MRCC_THEORY=n

export LARGE_FILES=TRUE
export USE_NOFSCHECK=y
export USE_NOIO=y
export ARMCI_NETWORK=GM

export USE_MPI=y
export USE_MPIF=y
export USE_MPIF4=y
export MPI_LOC=/opt/intel/impi/4.1.0.024/intel64/
export MPI_INCLUDE="-I/opt/intel/impi/4.1.0.024/intel64/include"
export MPI_LIB="-L/opt/intel/impi/4.1.0.024/intel64/lib"
export LIBMPI="-ldl -lmpi -lmpigf -lmpigi -lrt -lpthread"

export FC=ifort
export CC=icc

export USE_64TO32=y
export HAS_BLAS=y
export BLASOPT="-L/opt/intel/mkl/lib/intel64/ -lmkl_intel_lp64 -lmkl_sequential -lmkl_core -lpthread -lm"
export USE_SCALAPACK=y
export SCALAPACK="-L/opt/intel/mkl/lib/intel64/ -lmkl_scalapack_lp64 -lmkl_intel_lp64 -lmkl_sequential -lmkl_core -lmkl_blacs_intelmpi_lp64 -lpthread -lm"

export LIB_DEFINES="-DDFLT_TOT_MEM=16777216"


Maybe, "ld: cannot find -lga / ld: cannot find -larmci" is just the problem. If so, how to fix it?
Edited On 1:13:22 AM PST - Mon, Nov 9th 2015 by Hhaoissp


Who's here now Members 0 Guests 0 Bots/Crawler 0


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC