GNU make 3.82 issue

From NWChem

Viewed 5577 times, With a total of 10 Posts
Jump to: navigation, search

Just Got Here
Threads 1
Posts 1
Hi,

Nwchem 6.0 does not build with gnu make 3.82; Makefile works well with make 3.81.
Is there a way to modify the Makefile to make it comply with new version?

Thank you.

  • Bert Forum:Admin, Forum:Mod, NWChemDeveloper, bureaucrat, sysop
    Profile
    Send PM
Forum Vet
Threads 4
Posts 597
Can you post a little more detail as to what you mean by cannot build? Do you have a log of the errors?


Thanks,

Bert

Quote:Kernelpanic Mar 29th 2:19 pm
Hi,

Nwchem 6.0 does not build with gnu make 3.82; Makefile works well with make 3.81.
Is there a way to modify the Makefile to make it comply with new version?

Thank you.

Just Got Here
Threads 0
Posts 1
I am having the same difficulty with gnu make 3.82 (included in fedora 14). I would appreciate if you can provide me a fix or any hint.

Here is the log file generated at the time of failed build:


Making libraries in tools
...

GNUmakefile:71: *** mixed implicit and normal rules. Stop.
make[2]: *** [clean] Error 1
make[1]: *** [LINUX64-TCG-N.stamp] Error 2
make: *** [libraries] Error 1



Thank you.



Quote:Bert Mar 29th 8:49 pm
Can you post a little more detail as to what you mean by cannot build? Do you have a log of the errors?


Thanks,

Bert

Quote:Kernelpanic Mar 29th 2:19 pm
Hi,

Nwchem 6.0 does not build with gnu make 3.82; Makefile works well with make 3.81.
Is there a way to modify the Makefile to make it comply with new version?

Thank you.

  • Bert Forum:Admin, Forum:Mod, NWChemDeveloper, bureaucrat, sysop
    Profile
    Send PM
Forum Vet
Threads 4
Posts 597
I recommend for now to use GNU make 3.81. Our next release (there will be a development release shortly) will have the tools build using automake and this will eliminate the problem.

Bert

Quote:Bcheong Apr 1st 7:37 am
I am having the same difficulty with gnu make 3.82 (included in fedora 14). I would appreciate if you can provide me a fix or any hint.

Here is the log file generated at the time of failed build:


Making libraries in tools
...

GNUmakefile:71: *** mixed implicit and normal rules. Stop.
make[2]: *** [clean] Error 1
make[1]: *** [LINUX64-TCG-N.stamp] Error 2
make: *** [libraries] Error 1



Thank you.



Quote:Bert Mar 29th 8:49 pm
Can you post a little more detail as to what you mean by cannot build? Do you have a log of the errors?


Thanks,

Bert

Quote:Kernelpanic Mar 29th 2:19 pm
Hi,

Nwchem 6.0 does not build with gnu make 3.82; Makefile works well with make 3.81.
Is there a way to modify the Makefile to make it comply with new version?

Thank you.

  • Guest -
    Send PM
So this was a lame answer for me so I made a patch that got around the issue.

--- a/src/tools/global/GNUmakefile 2011-02-03 10:27:45.000000000 -0800
+++ b/src/tools/global/GNUmakefile 2011-03-19 22:27:49.499618776 -0700
@@ -68,7 +68,10 @@
$(LIBRARY): 
(echo TARGET is $(TARGET); cd ./src; $(MAKE) || exit 1;)

-$(TESTS) %.x: $(LIBRARY)
+%.x: $(LIBRARY)
+ (cd ./testing; $(MAKE) $@ || exit 1;)
+
+$(TESTS): $(LIBRARY)
	(cd ./testing; $(MAKE) $@  || exit 1;)

all: $(TESTS)

  • Bert Forum:Admin, Forum:Mod, NWChemDeveloper, bureaucrat, sysop
    Profile
    Send PM
Forum Vet
Threads 4
Posts 597
Not a lame answer at all. If you go to the download page the development version is available, which uses the new autobuild for global arrays...

Bert


Quote: Apr 26th 4:36 am
So this was a lame answer for me so I made a patch that got around the issue.

--- a/src/tools/global/GNUmakefile 2011-02-03 10:27:45.000000000 -0800
+++ b/src/tools/global/GNUmakefile 2011-03-19 22:27:49.499618776 -0700
@@ -68,7 +68,10 @@
$(LIBRARY): 
(echo TARGET is $(TARGET); cd ./src; $(MAKE) || exit 1;)

-$(TESTS) %.x: $(LIBRARY)
+%.x: $(LIBRARY)
+ (cd ./testing; $(MAKE) $@ || exit 1;)
+
+$(TESTS): $(LIBRARY)
	(cd ./testing; $(MAKE) $@  || exit 1;)

all: $(TESTS)[/quote]

  • Guest -
    Send PM
development program still doesn't work
I can't install nwchem 6.0 -april 2011 version on fedora 14 either. I believe I have similar problems with the tools and automake didn't help.

I have installed nwchem 6.0 on a older server, centos 5, but it seems there is problems w/ the newer os. Is there a way to fix this.. or will this be fixed? I"m not sure how to implement the patch above.


echo "No extra configuration libraries were added " >> NWCHEM_CONFIG
test -d /scratch/nwchem-6.0/lib/LINUX64 || mkdir -p /scratch/nwchem-6.0/lib/LINUX64
test -d /scratch/nwchem-6.0/bin/LINUX64 || mkdir -p /scratch/nwchem-6.0/bin/LINUX64
Making libraries in tools
../config/makefile.h:167: /scratch/nwchem-6.0/src/config/nwchem_config.h: No such file or directory
make[1]: warning: -jN forced in submake: disabling jobserver mode.
make[1]: *** No rule to make target `/scratch/nwchem-6.0/src/config/nwchem_config.h'. Stop.
make: *** [libraries] Error 1

  • Guest -
    Send PM
works
my bad, I set the proper environment variables and got it.

Gets Around
Threads 30
Posts 63
Quote: Apr 25th 9:36 pm
So this was a lame answer for me so I made a patch that got around the issue.

--- a/src/tools/global/GNUmakefile 2011-02-03 10:27:45.000000000 -0800
+++ b/src/tools/global/GNUmakefile 2011-03-19 22:27:49.499618776 -0700
@@ -68,7 +68,10 @@
$(LIBRARY): 
(echo TARGET is $(TARGET); cd ./src; $(MAKE) || exit 1;)

-$(TESTS) %.x: $(LIBRARY)
+%.x: $(LIBRARY)
+ (cd ./testing; $(MAKE) $@ || exit 1;)
+
+$(TESTS): $(LIBRARY)
	(cd ./testing; $(MAKE) $@  || exit 1;)

all: $(TESTS)[/quote]

hi.
I am a newcomer to NWCHEM.
I am having the same problem.
But can you please explain how to use your patch.
thank you.

Forum Vet
Threads 9
Posts 1398
Neo
What version of NWCHem are you using?
I believe this should have been fixed in 6.5

Gets Around
Threads 30
Posts 63
Quote:Edoapra Sep 9th 4:38 am
Neo
What version of NWCHem are you using?
I believe this should have been fixed in 6.5

Hello.
I am getting this issue on 6.1.1 on CentOS 7.
however NWCHEM 6.3 is giving a different OPENIB related issue, which I have already posted as a different thread.
In nwchem download page I can only see 6.3 as the latest stable release, no idea about 6.5.
As a very new user I am utterly confused on how can I be able to install it.

thank you.
Edited On 4:21:41 AM PDT - Tue, Sep 9th 2014 by Neo


Forum >> NWChem's corner >> Compiling NWChem



Who's here now Members 0 Guests 0 Bots/Crawler 1


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC