Cannot Define NWCHEM TOP in the Chosen Directory

From NWChem

Viewed 1549 times, With a total of 1 Posts
Jump to: navigation, search

Forum Regular
Threads 45
Posts 216
I am a new comer of NWCHEM.
Nwchem6.3 has been installed in MAC in the directory: /Users/computation/nwchem.
When I followed the instructions in the Nwchem6.1.1 manual and typed: export NWCHEM_TOP /Users/computation/nwchem, I was told " not a valid identifier". so NWCHEM_TOP failed to be defined
in my environment to be the path of the top level nwchem directory.
What is the problem here?
Thanks for your advice.


Thanks. This works!


In fact, I used the following lines from the manual to compile,
export USE_MPI
export NWCHEM_MODULES all
export OLD_GA yes
export NWCHEM_TARGET MACX
export NWCHEM_TOP=/Users/computation/nwchem
Howerver, when I went into the directory/src and typed " make nwchem_config", the terminal showed that
you must set NWCHEM_MODULES to the list of modules to be included in NWCHEM builds, and when I typed
further "make", it showed you must define NWCHEM_TARGET in your environment to be the name of the machine you wish to build for...
According to the manual, I have finished the two things.
What is the problem here?
Thanks for your advice.
Edited On 8:35:32 AM PDT - Thu, Jun 26th 2014 by Xiongyan21

Gets Around
Threads 18
Posts 133
Try

export NWCHEM_TOP=/Users/computation/nwchem 


Forum >> NWChem's corner >> Compiling NWChem



Who's here now Members 0 Guests 1 Bots/Crawler 0


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC