Incomplete EXTRA LIBS for LINUX64 target

From NWChem

Viewed 1685 times, With a total of 3 Posts
Jump to: navigation, search

Gets Around
Threads 24
Posts 86
Compiling nwchem with python support requires linking with library "-lz".
It happens if target is LINUX CYGNUS CYGWIN INTERIX, but if target is LINUX64 there is no "-lz" in EXTRA_LIBS, so linking fails with error.

I provide the patch that fixes this issue in latest Development snapshot June 09, 2014 Nwchem-dev.revision25716-src.2014-06-09

src/config/makefile_orig.h	2014-06-05 06:13:46.000000000 +0700
+++ src/config/makefile.h	2014-07-13 09:43:18.147836024 +0700
@@ -2101,7 +2101,7 @@
 
      ifeq ($(BUILDING_PYTHON),python)
 #   EXTRA_LIBS += -ltk -ltcl -L/usr/X11R6/lib -lX11 -ldl
-     EXTRA_LIBS +=    -lnwcutil  -lpthread -lutil -ldl
+     EXTRA_LIBS += -lz -lnwcutil  -lpthread -lutil -ldl
   LDOPTIONS = -Wl,--export-dynamic 
      endif
 ifeq ($(NWCHEM_TARGET),CATAMOUNT)
Edited On 10:05:33 PM PDT - Sat, Jul 12th 2014 by Vladimir

Forum Vet
Threads 10
Posts 1606
Vladimir,
Thanks for your feedback.
Could you please tell me what kind of linux distribution you are using?

Thanks, Edo

Gets Around
Threads 24
Posts 86
Hello, Edo.
I'm using Ubintu 14.04, Ubuntu 13.04 and Ubuntu 12.04.

I saw that it was already discussed in post
http://www.nwchem-sw.org/index.php/Special:AWCforum/post/quote/id1537
Quote:username
__Good__ (edit src/config/makefile.h, line 1914 and add -lz -lssl for python support)


but -lssl already fixed
Edited On 8:30:16 AM PDT - Fri, Jul 18th 2014 by Vladimir

Gets Around
Threads 24
Posts 86
fixed in http://www.nwchem-sw.org/download.php?f=Nwchem-dev.revision26027-src.2014-08-28.tar.gz

Thanks.


Forum >> NWChem's corner >> Running NWChem



Who's here now Members 0 Guests 1 Bots/Crawler 0


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC