Cray XC30 and CLE 5.2

From NWChem

Viewed 1080 times, With a total of 0 Posts
Jump to: navigation, search

Just Got Here
Threads 1
Posts 1
Hi All,

just a head's up for those who upgrade their XC30 to CLE 5.2 and are still using DMAPP as ARMCI_NETWORK. You need to recompile NWChem under CLE 5.2 when upgrading from older versions, as you do most other programs with CLE 5.2. I started getting GNI_RC_INVALID_PARAM errors in the new version which Cray support said can be avoided by setting the environment variable for runtime UGNI_CDM_MDD_DEDICATED=2, and they said will get fixed in an update to CLE 5.2.

So here's what I'm currently using for building:
module swap PrgEnv-cray PrgEnv-intel
module load craype-hugepages8M 

export NWCHEM_TOP=`pwd`
export NWCHEM_MODULES="all" 
export NWCHEM_TARGET=LINUX64
export ARMCI_NETWORK=DMAPP
export MPI_LOC=${MPICH_DIR}
export LIBMPI=" " 
export USE_MPI=y
export USE_MPIF=y
export USE_MPIF4=y
export LARGE_FILES=y 

cd $NWCHEM_TOP/src 

# Download Global Arrays 5.3 first...
tar x --directory=tools -f ~/ga-5-3.tgz
sed -i 's/GA_DIR = ga-5-2/GA_DIR = ga-5-3/' tools/GNUmakefile 

make realclean
make nwchem_config
make _FC=ifort FC=ftn


and for running nwchem:
module swap PrgEnv-cray PrgEnv-intel
module load craype-hugepages8M

setenv HUGETLB_MORECORE yes
setenv HUGETLB_DEFAULT_PAGE_SIZE 8M

#For CLE 5.2
export UGNI_CDM_MDD_DEDICATED=2


For GA 5.3 you need to have a hugepages module loaded at compile time, previously just runtime would work.

Regards,
Daniel.


Forum >> NWChem's corner >> Compiling NWChem



Who's here now Members 0 Guests 0 Bots/Crawler 1


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC