Compling NWChem with OpenMPI static linkage on Ubuntu 8.10

From NWChem

Viewed 2314 times, With a total of 2 Posts
Jump to: navigation, search

Just Got Here
Threads 1
Posts 2
Dear NWChem Users,
I am trying, unsuccessfully, to compile NWChem on Ubuntu 8.10 with static linkage to OpenMPI 1.8.1. OpenMPI 1.8.1 was compiled statically from scratch and it works perfectly with other already compiled tools (e.g. Gromacs).

During the compilation I get this error/warnings:

configure: WARNING: /usr/local/bin/ of with_mpi not parsed
checking whether a simple C MPI program compiles... yes
configure: WARNING: yes of with_mpi_ts not parsed
configure: searching for MPI_TS...
checking mpi.h usability... yes
checking mpi.h presence... yes
checking for mpi.h... yes
checking for library containing MPI_Init... no
configure: error: test for COMEX_NETWORK=MPI_TS failed
configure: error: ../../ga-5-2/comex/configure failed for comex


The script I am using is the following:

export NWCHEM_TOP=/home/sergio/Documents/nwchem-6.3
export MPI_INCLUDE=/usr/local/include/
export LIBMPI="-lmpi_f90 -lmpi_f77 -lmpi_usempi -lmpi_mpifh -lmpi -lopen-rte -lopen-pal -lm -lpthread -lrt -lnsl -lutil"
export ARMCI_NETWORK=MPI_TS
export USE_MPIF=y
export MPI_LIB=/usr/local/lib/
export USE_MPI=y
export MPI_LOC=/usr/local/bin/
export USE_MPIF4=y
export NWCHEM_MODULES=all
export NWCHEM_TARGET=LINUX64

Already tried:
- with or without export ARMCI_NETWORK=MPI_TS
- with or without --static in LIBMPI


Running the mpif90 -showme command I get:

gfortran -I/usr/local/include -pthread -I/usr/local/lib -Wl,-rpath -Wl,/usr/local/lib -Wl,--enable-new-dtags -L/usr/local/lib -lmpi_usempi -lmpi_mpifh -lmpi -lopen-rte -lopen-pal -lm -lpthread -lrt -lnsl -lutil

Running the mpicc -showme command I get:

gcc -I/usr/local/include/openmpi/opal/mca/hwloc/hwloc172/hwloc/include -I/usr/local/include/openmpi/opal/mca/event/libevent2021/libevent -I/usr/local/include/openmpi/opal/mca/event/libevent2021/libevent/include -I/usr/local/include -I/usr/local/include/openmpi -pthread -Wl,-rpath -Wl,/usr/local/lib -Wl,--enable-new-dtags -L/usr/local/lib -lmpi -lopen-rte -lopen-pal -lm -lpthread -lrt -lnsl -lutil

Thanks,
Sergio

Forum Vet
Threads 9
Posts 1492
Please try the following values for the env. variables
LIBMPI="-lmpi_usempi -lmpi_mpifh -lmpi -lopen-rte -lopen-pal -lm -lpthread -lrt -lnsl -lutil"
MPI_INCLUDE="/usr/local/include/openmpi/opal/mca/hwloc/hwloc172/hwloc/include -I/usr/local/include/openmpi/opal/mca/event/libevent2021/libevent -I/usr/local/include/openmpi/opal/mca/event/libevent2021/libevent/include -I/usr/local/include -I/usr/local/include/openmpi -pthread"

If you still get failure, please give us access to the following files

$NWCHEM_TOP/src/tools/build/config.log
$NWCHEM_TOP/src/tools/build/armci/config.log
$NWCHEM_TOP/src/tools/build/comex/config.log

Just Got Here
Threads 1
Posts 2
Hi,
thank you.
I used those settings but I still get the error.
After looking at the comex/config.log I added -ldl to the LIBMPI and compilation worked.

Thanks,
Sergio
Edited On 4:24:16 AM PDT - Tue, Jul 22nd 2014 by Sdecherchi


Forum >> NWChem's corner >> Compiling NWChem



Who's here now Members 0 Guests 0 Bots/Crawler 1


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC