compile nwchem-6-3.revision2-src.2013-10-17 with openmpi-1.6.4 on Ubuntu x86 64 GNU/Linux

From NWChem

Viewed 1643 times, With a total of 1 Posts
Jump to: navigation, search

Clicked A Few Times
Threads 10
Posts 26
Dear All,
I am trying to compile nwchem-6-3.revision2-src.2013-10-17 with openmpi-1.6.4 on a Ubuntu x86_64 GNU/Linux with the following building script.

export LARGE_FILES=TRUE
export TCGRSH=/usr/bin/ssh
export NWCHEM_TOP=~/himadri/executables/nwchem-6.3.revision2-src.2013-10-17
export NWCHEM_TARGET=LINUX64
export NWCHEM_MODULES=all
export USE_MPI=y
export USE_MPIF=y
export USE_MPIF4=y
export MPI_LOC=~/himadri/executables/openmpi.1.6
export MPI_LIB=~/himadri/executables/openmpi.1.6/lib
export MPI_INCLUDE=~/himadri/executables/openmpi.1.6/include
export LIBRARY_PATH=$LIBRARY_PATH:~/himadri/executables/openmpi.1.6/lib
export LIBMPI="-lmpi_f90 -lmpi_f77 -lmpi -lrt -lnsl -lutil -ldl -lm -Wl,--export-dynamic -lrt -lnsl -lutil"
export USE_NOFSCHECK=TRUE
export ARMCI_NETWORK=MPI-TS
cd $NWCHEM_TOP/src
make clean
make nwchem_config
make FC=gfortran


and end up with the following compilation error:
      • Building Parallel Tools ****

make all-recursive
Making all in comex
make[4]: *** No rule to make target `all'. Stop.
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [build/.libs/libga.a] Error 1
make: *** [libraries] Error 1


Can someone please suggest me where to make the correction in the compilation script? Thanks in advance.

Forum Vet
Threads 9
Posts 1522
Himadride
It's hard to tell what went wrong here.
Could you please try the following before recompiling
rm -rf $NWCHEM_TOP/src/tools/build
rm -rf $NWCHEM_TOP/src/tools/install


Forum >> NWChem's corner >> Compiling NWChem



Who's here now Members 0 Guests 1 Bots/Crawler 0


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC