Re: Beta version of NWChem 6.5 available for testing

From NWChem

Viewed 1331 times, With a total of 4 Posts
Jump to: navigation, search

Clicked A Few Times
Threads 6
Posts 13
Quote:Edoapra
Feedback -- of any kind -- from beta testers is very welcome.


Just a quick "compiled without problems" report, and also seems to be running fine. The ESP radii bug is still there, though: http://www.nwchem-sw.org/index.php/Special:AWCforum/st/id1397/Bug_in_ESP_radii_using_ECPs....

Added in edit:
Hmm, yeah, in order to be a bit more useful, the system it was compiled on was
  • Red Hat 4.4.6-4
  • kernel 2.6.32-279.19.1.el6.x86_64
  • AMD Opteron 6238 2.6 GHz
  • OpenMPI 1.6.5
  • OpenBLAS 0.2.11
  • gcc 4.7.2
Edited On 8:40:20 AM PDT - Sun, Aug 31st 2014 by Mpjohans

Clicked A Few Times
Threads 6
Posts 13
QA QM test results for 6.5 beta
Now had time to finish the doqmtests for the 6.5 beta version.

Failed tests
All(?) pspw tests. I remember these being a real hassle to get to compile correctly for a long time, so didn't look that much into it.
dplot
hess_nh3_ub3lyp
pspw
pspw_SiC
pspw_md
paw
pspw_polarizability
pspw_stress
band
talc
nwxc_pspw_1he
nwxc_pspw_3he
nwxc_pspw_1ne
nwxc_pspw_4n
nwxc_pspw_1ar
nwxc_pspw_4p
nwxc_pspw_1kr
nwxc_pspw_4as
nwxc_pspw_1xe
nwxc_pspw_4sb
ch4_zts
ch4cl_zts

Also, the Davidson restart tests fail, with "maximum exceeded restarting Davidson solver"
tddft_h2o_mxvc20
tddft_h2o_uhf_mxvc20

Memory and excution errors
Probably due to low memory on my machine, might be something else, though:
li2h2_tce_ccsd
qmmm_grad0
lys_qmmm
ethane_qmmm
tce_hyperpolar_ccsd_big

"Odd" failures
pbo_nesc1e, h2o_selci; failed with:
bas_input: nosegment option disabled

k6h2o; failed with:
Created fragment wat.frg_TMP
Unresolved atom types in fragment wat

neb-fch3cl:
Slightly different results from the onset

Failures probably due to new/different output in 6.5
tce_cr_eom_t_ch_rohf:
Finds the same energies but in different order

oniom4:
Apparently printout very different in 6.5-beta, causing parsing problems for test script

qmmm_opt0:
Plenty of _almost_ identical output...

o2_bnl, h2o_raman_3:
Apparently 6.5 just prints out much more detail that is caught by nwparse

aump2, n2_ccsd, grad_nh3_trimer, hess_nh3, hess_nh3_dimer, mp2_si2h6, cytosine_ccsd:
6.5 prints out SCS energies as well, confusing nwparse

"Last decimal" fails
Results differing in the last (or almost) decimal:
autosym
bsse_dft_trimer
cosmo_h3co
h2o_diag_to_cg_ub3lyp
dft_cr2
dft_x
dielsalder
dft_ozone
sadsmall
dft_xdm1
hi_zora_sf
o2_zora_so
ch3f-lc-wpbe
ch3f-lc-wpbeh
prop_ch3f
ch3radical_rot
ch3radical_unrot
cho_bp_props
prop_cg_nh3_b3lyp
acr_lcblyp
h2o-response
mep-test
tropt-ch3nh2
h3_dirdyvtst
h2o_hcons
etf_hcons
neb-isobutene
hess_biph

Forum Vet
Threads 9
Posts 1400
Mpjohans
Thank you very much for the valuable feedback.

Cheers, Edo

Gets Around
Threads 18
Posts 133
li2h2_tce_ccsd
I have built my 6.5 beta with gfortran 4.8.2, default compiler settings, on 64 bit Ubuntu 14.04 with OpenBLAS 0.2.11 as BLAS.

The li2h2_tce_ccsd completes during serial execution. The test evaluation fails, but I think that's the fault of the evaluation procedure rather than the actual output. Ignoring the first 6 normal modes, the results are in good agreement with the reference data:

Reference:
                   7           8           9          10          11          12
 
 Frequency        489.60      573.34      865.88      937.51     1072.22     1146.66
 
           1     0.10486     0.00000     0.00000     0.00000     0.65864    -0.69651
           2     0.00000     0.00000     0.64073    -0.65864     0.00000     0.00000
           3     0.00000     0.65862     0.00000     0.00000     0.00000     0.00000
           4     0.00000     0.00000    -0.11088     0.00000    -0.09461     0.00000
           5     0.26398     0.00000     0.00000     0.09461     0.00000     0.03974
           6     0.00000    -0.09463     0.00000     0.00000     0.00000     0.00000
           7     0.00000     0.00000     0.11088     0.00000    -0.09461     0.00000
           8    -0.26398     0.00000     0.00000     0.09461     0.00000    -0.03974
           9     0.00000    -0.09463     0.00000     0.00000     0.00000     0.00000
          10    -0.10486     0.00000     0.00000     0.00000     0.65864     0.69651
          11     0.00000     0.00000    -0.64073    -0.65864     0.00000     0.00000
          12     0.00000     0.65862     0.00000     0.00000     0.00000     0.00000


Computed by 6.5 beta:
                    7           8           9          10          11          12
 
 Frequency        489.60      573.32      865.88      937.51     1072.22     1146.66
 
           1     0.10486     0.00000    -0.00000    -0.00000    -0.65864    -0.69651
           2    -0.00000     0.00000     0.64073    -0.65864     0.00000     0.00000
           3     0.00000     0.65862     0.00000     0.00000     0.00000     0.00000
           4     0.00000     0.00000    -0.11088     0.00000     0.09461     0.00000
           5     0.26398     0.00000     0.00000     0.09461    -0.00000     0.03974
           6     0.00000    -0.09463     0.00000     0.00000     0.00000     0.00000
           7    -0.00000     0.00000     0.11088    -0.00000     0.09461    -0.00000
           8    -0.26398     0.00000     0.00000     0.09461    -0.00000    -0.03974
           9     0.00000    -0.09463     0.00000     0.00000     0.00000     0.00000
          10    -0.10486     0.00000    -0.00000     0.00000    -0.65864     0.69651
          11     0.00000     0.00000    -0.64073    -0.65864    -0.00000     0.00000
          12     0.00000     0.65862     0.00000     0.00000     0.00000     0.00000


This test stalls part way through when run with parallel execution. I am just running on a single machine using 2 or 4 cores in parallel, ARMCI_NETWORK=SOCKETS. The CPUs remain pinned at 100% but the job does not continue to make progress after about half of the CCSD energy calculations are complete. I first noticed this problem after the introduction of commit 25937 to tce_energy.F. If I revert that one file to the prior revision but otherwise leave the 6.5 beta code as-is, the li2h2_tce_ccsd test completes normally in parallel execution. Strangely none of the other TCE tests I have run stall in parallel. I don't know what is special about the interaction between this job and commit 25937.

Forum Vet
Threads 9
Posts 1400
li2h2_tce_ccsd has been removed from doqmtests since it use a functionality that has not been thoroughly tested


Forum >> NWChem's corner >> Compiling NWChem



Who's here now Members 0 Guests 0 Bots/Crawler 1


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC