Having Issue Compiling Nwchem 6.3

From NWChem

Viewed 1895 times, With a total of 9 Posts
Jump to: navigation, search

Gets Around
Threads 30
Posts 63
I have defined everything as asked in nwchem help section but still it raises ARMCI_NETWORK error, while trying to install NWCHEM 6.3.2.
OpenMPI installation also went fine.
Here is my .bashrc profile.
export NWCHEM_TOP=/home/abhisek/NWCHEM/nwchem-6.3.revision2-src.2013-10-17
export NWCHEM_TARGET=LINUX64
export ARMCI_NETWORK=OPENIB
export LARGE_FILES=TRUE
export NWCHEM_MODULES=all
export USE_MPI=y
export USE_MPIF=y
export USE_MPIF4=y
export MPI_LOC=/home/abhisek/opt/openmpi/
export LIBMPI="-lmpi_f90 -lmpi_f77 -lmpi -ldl -Wl,--export-dynamic -lnsl -lutil"
export MPI_LIB=/home/abhisek/opt/openmpi/lib
export MPI_INCLUDE=/home/abhisek/opt/openmpi/include


giving an error while i execute a command "make":
............
..........
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking whether it is safe to define __EXTENSIONS__... yes
checking for C compiler vendor... gnu
checking whether a simple C MPI program compiles... yes
checking for TARGET 64bit-ness... LINUX64
configure: searching for OPENIB...
checking infiniband/verbs.h usability... no
checking infiniband/verbs.h presence... no
checking for infiniband/verbs.h... no
configure: error: test for ARMCI_NETWORK=OPENIB failed
make[1]: *** [build/config.status] Error 1
make: *** [libraries] Error 1


Getting no idea on what to do..
Error remains same with nwchem-6.1.1


please help.
Edited On 2:38:32 AM PDT - Tue, Sep 9th 2014 by Neo

Forum Vet
Threads 9
Posts 1398
What is the output of the following command on your system

ls /usr/include/infiniband/verbs.h

Gets Around
Threads 30
Posts 63
Quote:Edoapra Sep 8th 9:53 am
What is the output of the following command on your system

ls /usr/include/infiniband/verbs.h[/quote]

It says :
ls: cannot access /usr/include/infiniband/verbs.h: No such file or directory



I am not being able to settle the issue with OPENIB.
Any help regarding this will be very helpful.
thank you.
Edited On 1:09:02 AM PDT - Tue, Sep 9th 2014 by Neo

Forum Vet
Threads 9
Posts 1398
Neo
Are you sure that you have Infiniband network hardware on your computer?
If this is the case, what linux distribution are you using?

Gets Around
Threads 30
Posts 63
Quote:Edoapra Sep 9th 4:36 am
Neo
Are you sure that you have Infiniband network hardware on your computer?
If this is the case, what linux distribution are you using?

I am using Fedora 20.
And I am not being able to install openib in my computer, which may fix the error. However if I exclude the line
export ARMCI_NETWORK=OPENIB
then also I am getting caught in error.
I am not getting it on what to do with AMRCI_NETWORK in .bashrc of mine which might help installing Nwchem6.3 or 6.1.1.
thank you.
Edited On 10:21:52 AM PDT - Wed, Sep 10th 2014 by Neo

Forum Vet
Threads 9
Posts 1398
What error do you get when you unset ARMCI_NETWORK=OPENIB?

Gets Around
Threads 30
Posts 63
Quote:Edoapra Sep 10th 2:32 pm
What error do you get when you unset ARMCI_NETWORK=OPENIB?


Hello Edoapra,
I have again tried again using 'yum install nwchem' removing OPENIB line from '.bashrc' .
It also did completed successfully. But I am not being able to invoke nwchem by just typing it.
When I give
locate nwchem

it produces following:
/etc/profile.d/nwchem.csh
/etc/profile.d/nwchem.sh
/usr/share/nwchem
/usr/share/doc/nwchem-common
/usr/share/doc/nwchem-common/LICENSE.TXT
/usr/share/nwchem/**
/usr/share/<many other>


Surprisingly, no " /usr/local/bin/ " file.
I am really confused on what to do with it. Its just trapping me every-way.
I have also installed openmpi using 'yum install'. But though it avoided OPENIB problem but still can't make 'em working.
:(
Edited On 1:22:36 AM PDT - Thu, Sep 11th 2014 by Neo

Forum Vet
Threads 9
Posts 1398
Neo
What output you get after typing the commands
rpm -q -l nwchem
rpm -q -i nwchem

Gets Around
Threads 30
Posts 63
Quote:Edoapra Sep 10th 2:32 pm
What error do you get when you unset ARMCI_NETWORK=OPENIB?


Hello.
The error I am getting when I unset OPENIB and perform the whole thing again from the begining:
as
1. set paths for NWCHEM_TOP and preinstalled OpenMPI.
2. make nwchem_config
3 make [giving error]
......
.......
........
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
configure: 
configure: Assembler
configure: 
checking dependency style of cc... gcc3
configure: 
configure: Fortran compiler
configure: 
checking whether we are using the GNU Fortran 77 compiler... yes
checking whether gfortran accepts -g... yes
checking for Fortran 77 compiler vendor... gnu
checking whether a simple Fortran MPI program compiles... no
configure: error: in `/home/abhisek/nwchem/nwchem-6.3.revision2-src.2013-10-17/src/tools/build':
configure: error: could not compile simple Fortran MPI program
See `config.log' for more details
make[1]: *** [build/config.status] Error 1
make: *** [libraries] Error 1


please help me out from this problem.
thank you.

Forum Vet
Threads 9
Posts 1398
Neo
This problem is cause by not having a working MPI installation as stated in the other thread
http://www.nwchem-sw.org/index.php/Special:AWCforum/st/id925/Nwchem_6.3_checking_whether_a...

Let's avoid having two parallel threads.


Forum >> NWChem's corner >> Compiling NWChem



Who's here now Members 0 Guests 0 Bots/Crawler 1


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC