Global Array Toolkit Compilation Errors on Mac OS X 10.9.5

From NWChem

Viewed 1931 times, With a total of 3 Posts
Jump to: navigation, search

Forum Regular
Threads 61
Posts 291
I have registered and downloaded ga-5-3.
When I compiled it on MAC OS X 10.9.5, the following message appeared after typing "make"
......
/usr/local/Cellar/mpich2/3.1.2/include/mpi.h:168:53: error: expected identifier
static const MPI_Datatype mpich_mpi_short_int MPICH_ATTR_TYPE_TAG_...
                                                   ^
/usr/local/Cellar/mpich2/3.1.2/include/mpi.h:25:109: note: expanded from macro
     'MPICH_ATTR_TYPE_TAG_LAYOUT_COMPATIBLE'
...__attribute__((type_tag_for_datatype(MPI,type,layout_compatible)))
^
fatal error: too many errors emitted, stopping now [-ferror-limit=]
20 errors generated.
make[3]: *** [src/collectives/message.lo] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Thanks for your advice!
Edited On 10:54:25 PM PDT - Sun, Oct 12th 2014 by Xiongyan21

Forum Vet
Threads 10
Posts 1643
1) We recommend using the ga-5-3 shipped with NWChem 6.5 and NOT the one from http://hpc.pnl.gov/globalarrays/

2) Please set CFLAGS_FORGA="-DMPICH_NO_ATTR_TYPE_TAGS" as described in

http://www.nwchem-sw.org/index.php/Compiling_NWChem#Compilation_of_NWChem_6.5_release_on_M...

Forum Regular
Threads 61
Posts 291
Thanks. I have re-exported CFLAGS_FORGA="-DMPICH_NO_ATTR_TYPE_TAGS", etc., but got the same error message.
Edited On 5:41:25 PM PDT - Tue, Oct 14th 2014 by Xiongyan21

Forum Regular
Threads 61
Posts 291
The total memory , GA , etc., all can be changed.
Edited On 3:31:20 AM PDT - Sat, Oct 18th 2014 by Xiongyan21


Forum >> NWChem's corner >> Compiling NWChem



Who's here now Members 0 Guests 1 Bots/Crawler 0


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC