NWCHEM Cannot Run On the Environment Although It Is Built

From NWChem

Viewed 665 times, With a total of 10 Posts
Jump to: navigation, search

Gets Around
Threads 33
Posts 138
Dear Doctors and Professors

When I recompiled NWCHEM6.6, although it was successfully built on macOS Sierra 10.12.2 with GCC6.3.0, mpich3.2_2 and Xcode8.0 with the following
gfortran -L/users/computation2/nwchem6.6/lib/MACX64 -L/users/computation2/nwchem6.6/src/tools/install/lib -o /users/computation2/nwchem6.6/bin/MACX64/nwchem nwchem.o stubs.o -lnwctask -lccsd -lmcscf -lselci -lmp2 -lmoints -lstepper -ldriver -loptim -lnwdft -lgradients -lcphf -lesp -lddscf -ldangchang -lguess -lhessian -lvib -lnwcutil -lrimp2 -lproperty -lsolvation -lnwints -lprepar -lnwmd -lnwpw -lofpw -lpaw -lpspw -lband -lnwpwlib -lcafe -lspace -lanalyze -lqhop -lpfft -ldplot -lnwpython -ldrdy -lvscf -lqmmm -lqmd -letrans -lpspw -ltce -lbq -lmm -lcons -lperfm -ldntmc -lccca -lnwcutil -lga -larmci -lpeigs -lperfm -lcons -lbq -lnwcutil -lnwclapack -lnwcblas /Library/Frameworks/Python.framework/versions/2.7/lib/python2.7/config/libpython2.7.a -lnwclapack -lnwcblas -L/usr/local/Cellar/mpich/3.2_2/lib -lmpifort -lmpi -lpmpi -lpthread
/bin/rm -f nwchem.o stubs.o
nwchem is built
the following error was encountered, e.g, in the case of QA test be,

0:spcart_bra2etran: nbf_xj.ne.nbf_sj (xj-sj) =:Received an Error in Communication
application called MPI_Abort(comm=0x84000004, 5) - process 0

...
 Superposition of Atomic Density Guess
-------------------------------------

Sum of atomic energies:         -14.57287345
------------------------------------------------------------------------
spcart_bra2etran: nbf_xj.ne.nbf_sj (xj-sj) = 5
------------------------------------------------------------------------
------------------------------------------------------------------------
current input line :
26: task scf energy
------------------------------------------------------------------------
------------------------------------------------------------------------
This error has not yet been assigned to a category
------------------------------------------------------------------------
For more information see the NWChem manual at http://www.nwchem-sw.org/index.php/NWChem_Documentation


For further details see manual section: No section for this category                                                                                                                                                                                                                                   
..

Command env|grep MPI_ gives
MPI_INCLUDE=/usr/local/Cellar/mpich/3.2_2/include
MPI_LIB=/usr/local/Cellar/mpich/3.2_2/lib


Does it mean there is some incompatibility and What should I do to remedy this?

From the successfully mpi built and fully tested DALTON2016.2 on the same environment, the following information may be helpful:

BLAS                     | /usr/lib/libblas.dylib
LAPACK | /usr/lib/liblapack.dylib

Very Best Regards!
Edited On 4:26:57 AM PST - Sat, Dec 31st 2016 by Xiongyan21

Forum Vet
Threads 7
Posts 1355
What is the output of
otool -L /users/computation2/nwchem6.6/bin/LINUX64/nwchem

Gets Around
Threads 33
Posts 138
Dear Dr. Edoapra

Command otool -L /users/computation2/nwchem6.6/bin/MACX64/nwchem exhibits

/users/computation2/nwchem6.6/bin/MACX64/nwchem:
/Library/Frameworks/Python.framework/Versions/2.7/Python (compatibility version 2.7.0, current version 2.7.0)
/usr/local/opt/mpich/lib/libmpifort.12.dylib (compatibility version 14.0.0, current version 14.0.0)
/usr/local/opt/mpich/lib/libmpi.12.dylib (compatibility version 14.0.0, current version 14.0.0)
/usr/local/opt/mpich/lib/libpmpi.12.dylib (compatibility version 14.0.0, current version 14.0.0)
/usr/local/opt/gcc/lib/gcc/6/libgfortran.3.dylib (compatibility version 4.0.0, current version 4.0.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1238.0.0)
/usr/local/lib/gcc/6/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)
/usr/local/opt/gcc/lib/gcc/6/libquadmath.0.dylib (compatibility version 1.0.0, current version 1.0.0)

You can see the incompatibility here

/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1238.0.0)

What should I do?

Very Best Regards!
Edited On 1:41:36 AM PST - Sat, Dec 31st 2016 by Xiongyan21

Forum Vet
Threads 7
Posts 1355
Not sure
I was not able to reproduce this failure on my Mac, that has Mac OS Sierra, too
The only difference in my build is that I am using OpenMPI (from Homebrew) instead of Mpich
$ otool -L ../bin/MACX64/nwchem
../bin/MACX64/nwchem:
/usr/local/opt/open-mpi/lib/libmpi_usempif08.20.dylib (compatibility version 21.0.0, current version 21.0.0)
/usr/local/opt/open-mpi/lib/libmpi_usempi_ignore_tkr.20.dylib (compatibility version 21.0.0, current version 21.0.0)
/usr/local/opt/open-mpi/lib/libmpi_mpifh.20.dylib (compatibility version 21.0.0, current version 21.0.0)
/usr/local/opt/open-mpi/lib/libmpi.20.dylib (compatibility version 21.0.0, current version 21.1.0)
/usr/local/opt/gcc/lib/gcc/6/libgfortran.3.dylib (compatibility version 4.0.0, current version 4.0.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1238.0.0)
/usr/local/lib/gcc/6/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)
/usr/local/opt/gcc/lib/gcc/6/libquadmath.0.dylib (compatibility version 1.0.0, current version 1.0.0

Gets Around
Threads 33
Posts 138
Thanks a lot for your time.
   In fact, this might be caused by the deletion of files in Cellar because GCC cannot be uninstalled
thoroughly. Although the operating system had been reinstalled, some default configuration
might not be automatically compatiaple with NWCHEM6.6 running.
My question is what files should be changed in Cellar or other file clips to make a parrallel run
start?
Thanks!
Very Best Regards!
Edited On 7:58:17 PM PST - Fri, Jan 20th 2017 by Xiongyan21

Forum Vet
Threads 7
Posts 1355
These are my settings for a quikc compilation of a small NWChem binary on MacOS Sierra using OpenMPi from Homebrew

export NWCHEM_TOP=............
export NWCHEM_TARGET=MACX64
export NWCHEM_MODULES='nwdft driver stepper vib hessian property solvation'
export USE_MPI=y
export EVENT_NOKQUEUE=1

export USE_INTERNALBLAS=y
unset BLASOPT
unset BLAS_LIB
unset LAPACK_LIB
unset MPI_LIB
unset MPI_INCLUDE
unset LIBMPI
export PATH=/usr/local/Cellar/open-mpi/2.0.1/bin/:$PATH

Gets Around
Threads 33
Posts 138
I have updated the operating system to macOS Sierra 10.12.3 and found some tests, e.g.,acr_lcblyp.nw, could pass, whether they ran sequentially or parallelly, but test Be.nw still failed with the following information

Summary of "ao basis" -> "ao basis" (cartesian)
------------------------------------------------------------------------------
Tag Description Shells Functions and Types
---------------- ------------------------------ ------ ---------------------
be cc-pVTZ 10 35 4s3p2d1f



Forming initial guess at       0.0s


     Superposition of Atomic Density Guess
-------------------------------------

Sum of atomic energies:         -14.57287345
from getmem: mem. needed= 275299 , mem. available= 252264
------------------------------------------------------------------------
texas: nerror called 0
------------------------------------------------------------------------
------------------------------------------------------------------------
current input line :
28: task scf energy
------------------------------------------------------------------------
------------------------------------------------------------------------
An error occured while computing integrals
------------------------------------------------------------------------
For more information see the NWChem manual at http://www.nwchem-sw.org/index.php/NWChem_Documentation


For further details see manual section:                                                                                                                                                                                                                                                                
0:texas: nerror called:Received an Error in Communication
application called MPI_Abort(comm=0x84000000, -1) - process 0
[unset]: write_line error; fd=-1 buf=:cmd=abort exitcode=-1

system msg for write_line failure : Bad file descriptor
Error no.                     1  in getmem  memory overflow : call no., amount requested :                   75               265356


I have added the line
memory stack 1500 mb heap 1000 mb global 2500 mb


Test tddft_ac_co.nw got the following mistake
Superposition of Atomic Density Guess
-------------------------------------

Sum of atomic energies:        -112.43383664
spcart_bra2etran: nbf_xj.ne.nbf_sj (xj-sj) = 5
------------------------------------------------------------------------
------------------------------------------------------------------------
current input line :
0:
------------------------------------------------------------------------
------------------------------------------------------------------------
This error has not yet been assigned to a category
------------------------------------------------------------------------
For more information see the NWChem manual at http://www.nwchem-sw.org/index.php/NWChem_Documentation


For further details see manual section: No section for this category                                                                                                                                                                                                                                   


What is the problem here?

Very Best Regards!
Edited On 7:23:24 PM PST - Tue, Jan 24th 2017 by Xiongyan21

Gets Around
Threads 33
Posts 138
This might be caused by the conflicts between NWCHEM6.6 and Dalton2016.2, LSDalton1.2 or Dirac16 on MacOS Sierra 10.12.1 and later, because sometimes command env|grep MPI_ exhibited
MPI_INCLUDE=/usr/local/Cellar/mpich/3.2_2/include
MPI_LIB=/usr/local/Cellar/mpich/3.2_2/lib
DIRAC_MPI_COMMAND=mpirun -np 4 ( DIRAC installation command)
or blank.

On previously released MacOS editions, no such phenomena were observed.

I will try to compile NWChem6.6 on a just released small but powerful HP Z2 mini G3 workstation,
where the CPU is Core i7 6700, which will have Fedora or RHEL desktop workstation installed.
Edited On 8:43:44 PM PST - Sun, Feb 12th 2017 by Xiongyan21

Forum Vet
Threads 7
Posts 1355
patch for gcc 6.1 and later
Have you applied the following patch for gcc 6.1 as described in the Download page
http://www.nwchem-sw.org/download.php?f=Gcc6_macs_optfix.patch.gz

Gets Around
Threads 33
Posts 138
Dear Dr. Edoapra
     Thanks a lot.  

     NWCHEM6.6 seems to be full-fledged after I have applied all the patches except 
those for the compilations under OpenSuse or Centos7.1, and recompiled it. Previously
I also applied those patches but NWCHEM6.6 cannot run due to the hostname problems.
I will not hesitate to find helps from you if I get stuck in the compilation of NWCHEM6.6
on my HP Z2 mini G3 workstation when the operating system is installed.



    I will try applying only one patch for macOS. 

    Very Best Regards!
Edited On 7:56:11 AM PST - Thu, Feb 2nd 2017 by Xiongyan21

Gets Around
Threads 33
Posts 138
If only the patch for mac is applied, the result calculated is the same.


Dft_he2+.nw gives the same results as those in dft_he+.out, both slightly different from those in dft_he+.out_old.
Edited On 2:09:57 AM PST - Thu, Feb 9th 2017 by Xiongyan21


Forum >> NWChem's corner >> Running NWChem



Who's here now Members 0 Guests 0 Bots/Crawler 1


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC