Failure to compile NWChem with MPICH on CentOS

From NWChem

Viewed 139 times, With a total of 11 Posts
Jump to: navigation, search

Clicked A Few Times
Threads 7
Posts 18
Hi folks,

I have tried to compile NWChem on CentOS 6 cluster (Rock cluster 6.1.1) with MPICH using the following script.

#!/bin/bash

module purge
module load /share/apps/modulefiles/gcc48 mvapich2-2.2b_intel2013 python2.7

export NWCHEM_TOP=/share/apps/nwchem-6.6
export NWCHEM_TARGET=LINUX64
export ARMCI_NETWORK=OPENIB
export CC=icc
export FC=ifort
export USE_ARUR=TRUE
export USE_NOFSCHECK=TRUE
export NWCHEM_FSCHECK=N
export LARGE_FILES=TRUE
export MRCC_THEORY=Y
export EACCSD=Y
export IPCCSD=Y
export CCSDTQ=Y
export CCSDTLR=Y
export NWCHEM_LONG_PATHS=Y
export PYTHONHOME=/share/apps/python
export PYTHONVERSION=2.7
export PYTHONLIBTYPE=so
export USE_PYTHON64=y
export HAS_BLAS=yes
export BLASOPT="-L$MKLROOT/lib/intel64/libmkl_intel_lp64.a -L$MKLROOT/lib/intel64/libmkl_core.a -L$MKLROOT/lib/intel64/libmkl_intel_thread.a -I$MKLROOT/include"
export BLAS_SIZE='4'
export MAKE=/usr/bin/make
export LD_LIBRARY_PATH=/share/apps/mpi/mvapich2-2.2b_intel2013/lib
export USE_MPI=y
export USE_MPIF=y
export USE_MPIF4=y
export MPIEXEC=/share/apps/mpi/mvapich2-2.2b_intel2013/bin/mpiexec
export MPI_LIB=/share/apps/mpi/mvapich2-2.2b_intel2013/lib
export MPI_INCLUDE=/share/apps/mpi/mvapich2-2.2b_intel2013/include
export LIBMPI="-lmpifort -Wl -rpath --enable-new-dtags -lmpi"
$MAKE nwchem_config NWCHEM_MODULES="all python" 2>&1 | tee ../make_nwchem_config_mpich.log
$MAKE 64_to_32 2>&1 | tee ../make_64_to_32_mpich.log
export MAKEOPTS="USE_64TO32=y"
$MAKE ${MAKEOPTS} 2>&1 | tee ../makefile.log


But, the last two lines of make process gave me the following error message.

test \! -f 64_to_32 -o \! -f 32_to_64 || rm -f 64_to_32 32_to_64
test -d /share/apps/nwchem-6.6/lib/LINUX64 || mkdir -p /share/apps/nwchem-6.6/lib/LINUX64
test -d /share/apps/nwchem-6.6/bin/LINUX64 || mkdir -p /share/apps/nwchem-6.6/bin/LINUX64
./util/util_nwchem_version.bash
Making libraries in tools
make[1]: Entering directory `/share/apps/nwchem-6.6/src/tools'

*** Building Parallel Tools ****

make[2]: Entering directory `/share/apps/nwchem-6.6/src/tools/build'
/usr/bin/make  all-recursive
make[3]: Entering directory `/share/apps/nwchem-6.6/src/tools/build'
Making all in comex
make[4]: Entering directory `/share/apps/nwchem-6.6/src/tools/build/comex'
make[4]: *** No rule to make target `all'.  Stop.
make[4]: Leaving directory `/share/apps/nwchem-6.6/src/tools/build/comex'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/share/apps/nwchem-6.6/src/tools/build'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/share/apps/nwchem-6.6/src/tools/build'
make[1]: *** [build/.libs/libga.a] Error 1
make[1]: Leaving directory `/share/apps/nwchem-6.6/src/tools'
make: *** [libraries] Error 1
~


Can anyone suggest me to fix this problem ? Thank you in advance.

Rangsiman

Forum Vet
Threads 7
Posts 1355
cd $NWCHEM_TOP/src/tools
rm -rf build install
make FC=ifort

If this still fails, please send make error log and $NWCHEM_TOP/src/tools/build/config.log

Clicked A Few Times
Threads 7
Posts 18
I already run your suggested commands. But there is still no nwchem.exe binary file in $NWCHEM_TOP/bin/LINUX64/ directory, that means the nwchem has not been compiled yet, right ?

Here is the tail of an output after running make FC=ifort.

/bin/sh ./libtool  --tag=CC   --mode=link icc       -o global/trace/collisions.x global/trace/collisions.o
libtool: link: icc -o global/trace/collisions.x global/trace/collisions.o
make[3]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build'
make[2]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build'
make[1]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build'

*** Installing Parallel Tools ****

make[1]: Entering directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build'
/usr/bin/make  install-recursive
make[2]: Entering directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build'
Making install in armci
make[3]: Entering directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build/armci'
/usr/bin/make  install-am
make[4]: Entering directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build/armci'
make[5]: Entering directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build/armci'
 /bin/mkdir -p '/share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib'
 /bin/sh ./libtool   --mode=install /usr/bin/install -c   libarmci.la '/share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib'
libtool: install: /usr/bin/install -c .libs/libarmci.lai /share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib/libarmci.la
libtool: install: /usr/bin/install -c .libs/libarmci.a /share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib/libarmci.a
libtool: install: chmod 644 /share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib/libarmci.a
libtool: install: ranlib /share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib/libarmci.a
libtool: finish: PATH="/share/apps/python/bin:/share/apps/mpi/mvapich2-2.2b_intel2013/bin:/share/apps/intel/composer_xe_2013_sp1.3.174/mpirt/bin/intel64:/share/apps/intel/composer_xe_2013_sp1.3.174/debugger/gdb/intel64_mic/py26/bin:/share/apps/intel/composer_xe_2013_sp1.3.174/debugger/gdb/intel64/py26/bin:/share/apps/intel/composer_xe_2013_sp1.3.174/bin/intel64:/share/apps/intel/composer_xe_2013_sp1.3.174/bin/intel64_mic:/share/apps/intel/composer_xe_2013_sp1.3.174/debugger/gui/intel64:/share/apps/gcc-4.8.2/bin:/usr/lib64/:/usr/lib64/qt-3.3/bin:/usr/lib/perfsonar/scripts:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/opt/bio/ncbi/bin:/opt/bio/mpiblast/bin:/opt/bio/EMBOSS/bin:/opt/bio/clustalw/bin:/opt/bio/tcoffee/bin:/opt/bio/hmmer/bin:/opt/bio/phylip/exe:/opt/bio/mrbayes:/opt/bio/fasta:/opt/bio/glimmer/bin:/opt/bio/glimmer/scripts:/opt/bio/gromacs/bin:/opt/bio/gmap/bin:/opt/bio/tigr/bin:/opt/bio/autodocksuite/bin:/opt/bio/wgs/bin:/opt/eclipse:/opt/ganglia/bin:/opt/ganglia/sbin:/opt/ibutils/bin:/usr/java/latest/bin:/opt/maven/bin:/opt/pdsh/bin:/opt/rocks/bin:/opt/rocks/sbin:/opt/condor/bin:/opt/condor/sbin:/opt/gridengine/bin/linux-x64:/home/rangsiman/bin:/sbin" ldconfig -n /share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib
----------------------------------------------------------------------
Libraries have been installed in:
   /share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,-rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
 /bin/mkdir -p '/share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/include'
 /usr/bin/install -c -m 644 ../../ga-5-4/armci/src/include/armci.h ../../ga-5-4/armci/src/include/gpc.h ../../ga-5-4/armci/src/include/message.h ../../ga-5-4/armci/src/include/parmci.h '/share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/include'
make[5]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build/armci'
make[4]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build/armci'
make[3]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build/armci'
Making install in .
make[3]: Entering directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build'
make[4]: Entering directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build'
 /bin/mkdir -p '/share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib'
 /bin/sh ./libtool   --mode=install /usr/bin/install -c   libga.la '/share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib'
libtool: install: /usr/bin/install -c .libs/libga.lai /share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib/libga.la
libtool: install: /usr/bin/install -c .libs/libga.a /share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib/libga.a
libtool: install: chmod 644 /share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib/libga.a
libtool: install: ranlib /share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib/libga.a
libtool: finish: PATH="/share/apps/python/bin:/share/apps/mpi/mvapich2-2.2b_intel2013/bin:/share/apps/intel/composer_xe_2013_sp1.3.174/mpirt/bin/intel64:/share/apps/intel/composer_xe_2013_sp1.3.174/debugger/gdb/intel64_mic/py26/bin:/share/apps/intel/composer_xe_2013_sp1.3.174/debugger/gdb/intel64/py26/bin:/share/apps/intel/composer_xe_2013_sp1.3.174/bin/intel64:/share/apps/intel/composer_xe_2013_sp1.3.174/bin/intel64_mic:/share/apps/intel/composer_xe_2013_sp1.3.174/debugger/gui/intel64:/share/apps/gcc-4.8.2/bin:/usr/lib64/:/usr/lib64/qt-3.3/bin:/usr/lib/perfsonar/scripts:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/opt/bio/ncbi/bin:/opt/bio/mpiblast/bin:/opt/bio/EMBOSS/bin:/opt/bio/clustalw/bin:/opt/bio/tcoffee/bin:/opt/bio/hmmer/bin:/opt/bio/phylip/exe:/opt/bio/mrbayes:/opt/bio/fasta:/opt/bio/glimmer/bin:/opt/bio/glimmer/scripts:/opt/bio/gromacs/bin:/opt/bio/gmap/bin:/opt/bio/tigr/bin:/opt/bio/autodocksuite/bin:/opt/bio/wgs/bin:/opt/eclipse:/opt/ganglia/bin:/opt/ganglia/sbin:/opt/ibutils/bin:/usr/java/latest/bin:/opt/maven/bin:/opt/pdsh/bin:/opt/rocks/bin:/opt/rocks/sbin:/opt/condor/bin:/opt/condor/sbin:/opt/gridengine/bin/linux-x64:/home/rangsiman/bin:/sbin" ldconfig -n /share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib
----------------------------------------------------------------------
Libraries have been installed in:
   /share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,-rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
 /bin/mkdir -p '/share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/bin'
  /bin/sh ./libtool   --mode=install /usr/bin/install -c global/trace/adjust.x global/trace/collisions.x '/share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/bin'
libtool: install: /usr/bin/install -c global/trace/adjust.x /share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/bin/adjust.x
libtool: install: /usr/bin/install -c global/trace/collisions.x /share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/bin/collisions.x
 /bin/mkdir -p '/share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/bin'
 /usr/bin/install -c tools/ga-config '/share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/bin'
 /bin/mkdir -p '/share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/include'
 /usr/bin/install -c -m 644 ../ga-5-4/ma/error.h ../ga-5-4/ma/macdecls.h ../ga-5-4/ma/macommon.h ../ga-5-4/ma/maf2c.fh ma/mafdecls.fh ma/matypes.h ../ga-5-4/ma/scope.h ../ga-5-4/ma/string-util.h ../ga-5-4/ma/table.h ../ga-5-4/global/src/gacommon.h ../ga-5-4/global/src/ga.h global/src/global.fh ../ga-5-4/global/src/ga-papi.h ../ga-5-4/global/src/ga-mpi.h ../ga-5-4/global/src/ga-mpi.fh ../ga-5-4/pario/dra/dra.fh ../ga-5-4/pario/dra/dra.h ../ga-5-4/pario/eaf/eaf.fh ../ga-5-4/pario/eaf/eaf.h ../ga-5-4/pario/elio/chemio.h ../ga-5-4/pario/elio/elio.h ../ga-5-4/pario/sf/coms.h ../ga-5-4/pario/sf/sf.fh ../ga-5-4/pario/sf/sf.h gaf2c/typesf2c.h gaf2c/farg.h ../ga-5-4/tcgmsg/tcgmsg.fh ../ga-5-4/tcgmsg/tcgmsg.h ../ga-5-4/tcgmsg/tcgmsg-mpi/msgtypesc.h ../ga-5-4/tcgmsg/tcgmsg-mpi/msgtypesf.h '/share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/include'
 /bin/mkdir -p '/share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/include'
 /usr/bin/install -c -m 644 global/src/ga-wapi.h '/share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/include'
make[4]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build'
make[3]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build'
make[2]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build'
make[1]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src/tools/build'


I also attached you the config.log with this link [1]

What should I do then ?

Rangsiman

Forum Vet
Threads 7
Posts 1355
you still need one more step

cd $NWCHEM_TOP/src
make FC=ifort link

Clicked A Few Times
Threads 7
Posts 18
Here's the error after running make FC=ifort link.

nwchem.F(663): (col. 16) remark: BLOCK WAS VECTORIZED
nwchem.F(666): (col. 13) remark: vectorization support: reference status has unaligned access
nwchem.F(666): (col. 13) remark: vectorization support: reference __STRLITPACKVAR_161 has unaligned access
nwchem.F(666): (col. 13) remark: vectorization support: unaligned access used inside loop body
nwchem.F(666): (col. 13) remark: loop was not vectorized: vectorization possible but seems inefficient
nwchem.F(666): (col. 13) remark: vectorization support: reference status has unaligned access
nwchem.F(666): (col. 13) remark: vectorization support: unaligned access used inside loop body
nwchem.F(666): (col. 13) remark: BLOCK WAS VECTORIZED
nwchem.F(460): (col. 10) remark: vectorization support: reference cstart has unaligned access
nwchem.F(460): (col. 10) remark: vectorization support: reference __STRLITPACKVAR_103 has unaligned access
nwchem.F(460): (col. 10) remark: vectorization support: unaligned access used inside loop body
nwchem.F(460): (col. 10) remark: loop was not vectorized: vectorization possible but seems inefficient
nwchem.F(463): (col. 11) remark: vectorization support: reference cstart has unaligned access
nwchem.F(463): (col. 11) remark: vectorization support: reference __STRLITPACKVAR_102 has unaligned access
nwchem.F(463): (col. 11) remark: vectorization support: unaligned access used inside loop body
nwchem.F(463): (col. 11) remark: loop was not vectorized: vectorization possible but seems inefficient
nwchem.F(465): (col. 11) remark: vectorization support: reference cstart has unaligned access
nwchem.F(465): (col. 11) remark: vectorization support: reference __STRLITPACKVAR_101 has unaligned access
nwchem.F(465): (col. 11) remark: vectorization support: unaligned access used inside loop body
nwchem.F(465): (col. 11) remark: loop was not vectorized: vectorization possible but seems inefficient
ifort -i8 -align -fpp -vec-report6 -fimf-arch-consistency=true -finline-limit=250 -O2 -g -fp-model source  -I.  -I/share/apps/nwchem-6.6/nwchem-6.6/src/include -I/share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/include -DEXT_INT -DLINUX -DLINUX64 -DIFCV8 -DIFCLINUX -DPARALLEL_DIAG -DCOMPILATION_DATE="'`date +%a_%b_%d_%H:%M:%S_%Y`'" -DCOMPILATION_DIR="'/share/apps/nwchem-6.6/nwchem-6.6'" -DNWCHEM_BRANCH="'6.6'"  -c -o stubs.o stubs.F
make[1]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src'
ifort -i8 -align -fpp -vec-report6 -fimf-arch-consistency=true -finline-limit=250 -O2 -g -fp-model source  -Wl,--export-dynamic  -L/share/apps/nwchem-6.6/nwchem-6.6/lib/LINUX64 -L/share/apps/nwchem-6.6/nwchem-6.6/src/tools/install/lib  -o /share/apps/nwchem-6.6/nwchem-6.6/bin/LINUX64/nwchem nwchem.o stubs.o -lnwctask -lccsd -lmcscf -lselci -lmp2 -lmoints -lstepper -ldriver -loptim -lnwdft -lgradients -lcphf -lesp -lddscf -ldangchang -lguess -lhessian -lvib -lnwcutil -lrimp2 -lproperty -lsolvation -lnwints -lprepar -lnwmd -lnwpw -lofpw -lpaw -lpspw -lband -lnwpwlib -lcafe -lspace -lanalyze -lqhop -lpfft -ldplot -lnwpython -ldrdy -lvscf -lqmmm -lqmd -letrans -lpspw -ltce -lbq -lmm -lcons -lperfm -ldntmc -lccca -lnwcutil -lga -larmci -lpeigs -lperfm -lcons -lbq -lnwcutil /share/apps/python/lib64/python2.7/config/libpython2.7.so -L/share/apps/nwchem-6.6/OpenBLAS-RK/lib/ -lopenblas -lpthread -lrt  -lnwclapack  -lnwcblas   -L/share/apps/mpi/mvapich2-2.2b_intel2013/lib -lmpifort -Wl -rpath --enable-new-dtags -lmpi   -libverbs   -lrt  -lpthread  -lnwcutil -lpython2.7 -lpthread -ldl -lutil -lm
ifort: error #10236: File not found:  '/share/apps/python/lib64/python2.7/config/libpython2.7.so'
ifort: command line warning #10157: ignoring option '-W'; argument is of wrong type
ifort: command line warning #10006: ignoring unknown option '-rpath'
ifort: command line warning #10006: ignoring unknown option '-fenable-new-dtags'
make: *** [link] Error 1


Do I have to deal with python library or you have any suggestion ?

Rangsiman

Clicked A Few Times
Threads 7
Posts 18
I just now fixed that error, but, I then got a new error as following.

sort.o soluf.o sonenorm.o soort.o sort.o sorteig.o tred22.o treesort3.o tresid.o util.o xerbla.o mapchk.o pdiff.o pgexit.o reducemap.o pstebz10.o pstebz11.o inv_it4.o inv_it5.o inv_it3.o peigs_tldlfact.o clustrf5.o r_ritz.o gdot.o
ar: illegal option -- U
Usage: ar [emulation options] [-]{dmpqrstx}[abcfilNoPsSuvV] [member-name] [count] archive-file file...
       ar -M [<mri-script]
 commands:
  d            - delete file(s) from the archive
  m[ab]        - move file(s) in the archive
  p            - print file(s) found in the archive
  q[f]         - quick append file(s) to the archive
  r[ab][f][u]  - replace existing or insert new file(s) into the archive
  t            - display contents of archive
  x[o]         - extract file(s) from the archive
 command specific modifiers:
  [a]          - put file(s) after [member-name]
  [b]          - put file(s) before [member-name] (same as [i])
  [D]          - use zero for timestamps and uids/gids
  [N]          - use instance [count] of name
  [f]          - truncate inserted file names
  [P]          - use full path names when matching
  [o]          - preserve original dates
  [u]          - only replace files that are newer than current archive contents
 generic modifiers:
  [c]          - do not warn if the library had to be created
  [s]          - create an archive index (cf. ranlib)
  [S]          - do not build a symbol table
  [T]          - make a thin archive
  [v]          - be verbose
  [V]          - display the version number
  @<file>      - read options from <file>
 emulation options:
  No emulation specific options
ar: supported targets: elf64-x86-64 elf32-i386 a.out-i386-linux pei-i386 pei-x86-64 elf64-l1om elf64-little elf64-big elf32-little elf32-big srec symbolsrec verilog tekhex binary ihex
make[3]: *** [all] Error 1
make[3]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src/peigs/src/c'
make[2]: *** [lib] Error 2
make[2]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src/peigs'
make[1]: *** [peigs_stamp] Error 1
make[1]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src/peigs'
make: *** [libraries] Error 1

Forum Vet
Threads 7
Posts 1355
Why are using python from /share/apps and not the default Centos python?
With Centos 6, the following env. variables should work for the rpm based python

export PYTHONVERSION=2.6
export PYTHONHOME=/usr
export USE_PYTHONCONFIG=1

Clicked A Few Times
Threads 7
Posts 18
Thanks for your suggestion. Although I used python 2.6, I still got an error as I mentioned.

...
...
...
  [c]          - do not warn if the library had to be created
  [s]          - create an archive index (cf. ranlib)
  [S]          - do not build a symbol table
  [T]          - make a thin archive
  [v]          - be verbose
  [V]          - display the version number
  @<file>      - read options from <file>
 emulation options:
  No emulation specific options
ar: supported targets: elf64-x86-64 elf32-i386 a.out-i386-linux pei-i386 pei-x86-64 elf64-l1om elf64-little elf64-big elf32-little elf32-big srec symbolsrec verilog tekhex binary ihex
make[3]: *** [all] Error 1
make[3]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src/peigs/src/c'
make[2]: *** [lib] Error 2
make[2]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src/peigs'
make[1]: *** [peigs_stamp] Error 1
make[1]: Leaving directory `/share/apps/nwchem-6.6/nwchem-6.6/src/peigs'
make: *** [libraries] Error 1

Forum Vet
Threads 7
Posts 1355
please unset USE_ARUR, e.g. execute the command

unset  USE_ARUR

The failure you just reported has nothing to do with python

Clicked A Few Times
Threads 7
Posts 18
Edoapra,

...Sorry for late reply. After several attempts to compile nwchem with mpich, the admin of linux cluster I am using could compile an executable (in his own directory, /home/...) using the following script.

#!/bin/bash

module purge
module load /share/apps/modulefiles/gcc48 mvapich2-2.2b_intel2013 python2.7

export MKLROOT=/share/apps/intel/composer_xe_2013_sp1.3.174/mkl
export NWCHEM_TOP=/home/ittipat/installer/nwchem-6.6
export NWCHEM_TARGET=LINUX64
export ARMCI_NETWORK=OPENIB
export CC=icc
export FC=ifort link
#export USE_ARUR=TRUE
export USE_NOFSCHECK=TRUE
export NWCHEM_FSCHECK=N
export LARGE_FILES=TRUE
export MRCC_THEORY=Y
export EACCSD=Y
export IPCCSD=Y
export CCSDTQ=Y
export CCSDTLR=Y
export NWCHEM_LONG_PATHS=Y
export PYTHONHOME=/usr
#export PYTHON_LIB=
export PYTHONVERSION=2.6
export USE_PYTHONCONFIG=1
#export PYTHONLIBTYPE=so
#export USE_PYTHON64=y
export HAS_BLAS=yes
export BLAS_LOC=${MKLROOT}/lib/intel64
export BLASOPT="-lmkl_intel_ilp64 -lmkl_intel_thread -lmkl_core -liomp5 -lpthread -lm -ldl"
export BLAS_SIZE='4'
export MAKE=/usr/bin/make
export LD_LIBRARY_PATH="/share/apps/mpi/mvapich2-2.2b_intel2013/lib:/share/apps/python/lib/:/export/apps/intel/composer_xe_2013_sp1.3.174/compiler/lib/intel64/"
export USE_MPI=y
export USE_MPIF=y
export USE_MPIF4=y
export MPIEXEC=/share/apps/mpi/mvapich2-2.2b_intel2013/bin/mpiexec
export MPI_LIB=/share/apps/mpi/mvapich2-2.2b_intel2013/lib
export MPI_INCLUDE=/share/apps/mpi/mvapich2-2.2b_intel2013/include
#export LIBMPI="-lmpi -L$MKLROOT/lib/intel64 -lmpifort -rpath --enable-new-dtags"
export LDFLAGS="-L/export/apps/compilers/intel2013/composer_xe_2013_sp1.3.174/compiler/lib/intel64/"
#export LIBMPI="-lmpifort -Wl -rpath --enable-new-dtags -lmpi"

#make nwchem_config NWCHEM_MODULES="all python" 
#make -j4 64_to_32
#make -j4

#make nwchem_config NWCHEM_MODULES="all python" 2>&1 | tee ../make_nwchem_config_mpich.log
#make 64_to_32 2>&1 | tee ../make_64_to_32_mpich.log
#make 2>&1 | tee ../makefile.log

$MAKE realclean
$MAKE nwchem_config NWCHEM_MODULES="all python" 2>&1 | tee ../make_nwchem_config_mpich.log
$MAKE 64_to_32 2>&1 | tee ../make_64_to_32_mpich.log
export MAKEOPTS="USE_64TO32=y"
$MAKE ${MAKEOPTS} 2>&1 | tee ../makefile.log



He (admin) then copy an executable binary to the shared directory. Then I tried to run nwchem with a simple calculation using serial command run, they are,

$ module purge
$ module load mvapich2-2.2b_intel2013
$ nwchem optimize-water-molecule.nw

Unfortunately, I got the error message suddenly. So, please allow me to post the error, which related to the program compilation, here.


           Job information
           ---------------

    hostname        = castor.narit.or.th
    program         = nwchem
    date            = Mon Sep 11 15:38:49 2017

    compiled        = Mon_Sep_11_13:59:20_2017
    source          = /share/apps/nwchem-6.6
    nwchem branch   = 6.6
    nwchem revision = 27746
    ga revision     = 10594
    input           = optimize-water-molecule.nw
    prefix          = h2o.
    data base       = ./h2o.db
    status          = startup
    nproc           =        1
    time left       =     -1s



           Memory information
           ------------------

    heap     =   32767994 doubles =    250.0 Mbytes
    stack    =   32767999 doubles =    250.0 Mbytes
    global   =   65536000 doubles =    500.0 Mbytes (distinct from heap & stack)
    total    =  131071993 doubles =   1000.0 Mbytes
    verify   = yes
    hardfail = no


           Directory information
           ---------------------

  0 permanent = .
  0 scratch   = .




                                NWChem Input Module
                                -------------------


                             Water in 6-31g basis set
                             ------------------------
0:Segmentation Violation error, status=: 11
(rank:0 hostname:castor.narit.or.th pid:887):ARMCI DASSERT fail. ../../ga-5-4/armci/src/common/signaltrap.c:SigSegvHandler():315 cond:0
Last System Error Message from Task 0:: Bad address
[unset]: aborting job:
application called MPI_Abort(comm=0x84000001, 11) - process 0


I'm wondering that, would copying the binary file to other place cause such that error about segmentation violation? Do you have any suggestions to overcome this kind of error?

Thanks in advance.

Cheers,
Rangsiman

Forum Vet
Threads 7
Posts 1355
Wrong combination

export BLASOPT="-lmkl_intel_ilp64 -lmkl_intel_thread -lmkl_core -liomp5 -lpthread -lm -ldl"
export BLAS_SIZE='4'


ilp64 requires BLAS_SIZE=8
lp64 requires BLAS_SIZE=4

Easiest fix tor try (change ilp64 to lp64)


export BLASOPT="-lmkl_intel_lp64 -lmkl_intel_thread -lmkl_core -liomp5 -lpthread -lm -ldl"
export BLAS_SIZE=4
cd $NWCHEM_TOP/src
make FC=ifort link

Clicked A Few Times
Threads 7
Posts 18
Edoapra,

Thanks a lot for your useful suggestion. Right now I can run nwchem normally.

Cheers,
Rangsiman


Forum >> NWChem's corner >> Compiling NWChem



Who's here now Members 0 Guests 0 Bots/Crawler 1


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC