Compilation of NWCHEM6.8 Failed on macOS High Sierra with Openmpi 3.0.0 1

From NWChem

Viewed 860 times, With a total of 0 Posts
Jump to: navigation, search

Forum Regular
Threads 59
Posts 283
Dear All

    The following error appeared during the compilation of NWCHEM6.8 on maxOS High Sierra
10.13.2 with gcc 7.2.0 and openmpi 3.0.0_1, although the following two lines were added
export MPI_INCLUDE=/usr/local/Cellar/open-mpi/3.0.0_1/include
export MPI_LIB=/usr/local/Cellar/open-mpi/3.0.0_1/lib

"...

configure: searching for MPI_TS...
checking mpi.h usability... yes
checking mpi.h presence... yes
checking for mpi.h... yes
checking for library containing MPI_Init... no
configure: error: test for COMEX_NETWORK=MPI_TS failed
configure: error: ../../ga-5.6.3/comex/configure failed for comex
make[1]: *** [build/config.status] Error 1
make: *** [libraries] Error 1"

  The openmpi installation information from the terminal is
...
 Already downloaded: /Users/apple/Library/Caches/Homebrew/open-mpi-3.0.0_1.high_sierra.bottle.tar.gz
==> Pouring open-mpi-3.0.0_1.high_sierra.bottle.tar.gz
 /usr/local/Cellar/open-mpi/3.0.0_1: 715 files, 9.7MB ,
but which mpi and mpi -v all got no response.


What is missing here?

 Thanks a lot!

Very Best Regards!
Edited On 8:41:17 PM PST - Sun, Jan 7th 2018 by Xiongyan21


Forum >> NWChem's corner >> Compiling NWChem



Who's here now Members 0 Guests 1 Bots/Crawler 0


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC