ioctl error when using nwchem with ase

From NWChem

Viewed 440 times, With a total of 1 Posts
Jump to: navigation, search

Just Got Here
Threads 1
Posts 1
I am trying to determine the energy of H3O+ in ASE using NWChem as a calculator. My code is:
from ase import Atoms
from ase.calculators.nwchem import NWChem

structcalc = NWChem(label="calc/nwchem", maxiter=2000, charge = +1)

a = Atoms("OH3",[(0,0,0),(-0.96,0,0),(0.9294,0.240,0),(-0.9294,0.240,0)])


However when I run this code, I get the following error returned to me in SLURM

module: loading 'nwchem/6.8-openmpi'
Last System Error Message from Task 0:: Inappropriate ioctl for device
Traceback (most recent call last):
 File "", line 23, in <module>
File "/users/guest486/.local/lib/python2.7/site-packages/ase/", line 664, in get_potential_energy
energy = self._calc.get_potential_energy(self)
File "/users/guest486/.local/lib/python2.7/site-packages/ase/calculators/", line 505, in get_potential_energy
energy = self.get_property('energy', atoms)
File "/users/guest486/.local/lib/python2.7/site-packages/ase/calculators/", line 552, in get_property
self.calculate(atoms, [name], system_changes)
File "/users/guest486/.local/lib/python2.7/site-packages/ase/calculators/", line 716, in calculate
ase.calculators.calculator.CalculationFailed: nwchem in calc returned an error: 143

What does the Inappropriate ioctl for device error mean?

Additionally I have already tried running several other jobs and many of them return a similar error.

Forum Vet
Threads 12
Posts 1675
It's hard to tell what is going wrong here without the NWChem output file

Forum >> NWChem's corner >> Running NWChem

Who's here now Members 0 Guests 1 Bots/Crawler 0

AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC