Run parallel

From NWChem

Viewed 2237 times, With a total of 2 Posts
Jump to: navigation, search

  • Guest -
    Send PM
I am running the pre-compiled NWCHem 6.0 Linux binary on a XEON machine with 4 processors and Suse Linux without problems in sequential mode. However, I have not been able to run it in parallel mode.
I created the nwchem.p file according to the intructions in the Documentation link, all the path stuff is apparently O.K. but any trial fails with error messages like that:
 sock=0, pid=1, nsent=-1, len=56
1: snd_remote a: writing message to socket 39999999
system error message: Bad file descriptor
(and a few similar lines....)

The last entry in the output file has a message:
 3: ARMCI aborting 0 (0)
Creating: localhost, host, file= etc with apparently correct entries


I suspect that I am lacking something to run parallel
Can somebody help ?

Thanks
Luis

  • Guest -
    Send PM
Hi Luis,

Can you send the command you are using to run in parallel ?

Best,
-Niri

  • Guest -
    Send PM
Thanks, Niri

The command, run from directory /home/lfp/nwchem, is

bin/parallel bin/nwchem fileinp.nw > fileout.out &

I created the file nwchem.p in directory /home/lfp/nwchem/bin with the entry:

 lfp atenea 4 /home/lfp/nwchem/bin/nwchem /home/lfp/nwchem

NWChem starts, the output file is created (input info properly read, basis set stuff, etc correct) but the program aborts after a couple seconds and the last lines in the output file are:

3: ARMCI aborting 0 (0)
Creating: localhost=atenea, host=atenea, usr=lfp,
file=/home/lfp/nwchem/bin/nwchem, port=9427

Thanks again
Best regards

Luis


Forum >> NWChem's corner >> Running NWChem



Who's here now Members 0 Guests 1 Bots/Crawler 0


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC