ggg

From NWChem

Viewed 2285 times, With a total of 5 Posts
Jump to: navigation, search

Clicked A Few Times
Threads 12
Posts 43
ddd

Clicked A Few Times
Threads 12
Posts 43
I can submit post in this forum, get the following error: the specified URL is not valid.

Clicked A Few Times
Threads 12
Posts 43
Surprising
Hi admin and everyone,
I encounter a problem with compiling NWChem with OpenIB, the error is follows:

grep: /opt/torque/lib/libtorque.la: No such file or directory
/bin/sed: can't read /opt/torque/lib/libtorque.la: No such file or directory
libtool: link: `/opt/torque/lib/libtorque.la' is not a valid libtool archive
make[5]: *** [libarmci.la] Error 1
make[5]: *** Waiting for unfinished jobs....
libtool: link: ranlib .libs/libarmcii.a
libtool: link: rm -fr .libs/libarmcii.lax
libtool: link: ( cd ".libs" && rm -f "libarmcii.la" && ln -s "../libarmcii.la" "libarmcii.la" )
make[4]: *** [all] Error 2
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [build/.libs/libga.a] Error 1
make: *** [libraries] Error 1

wangjb

Clicked A Few Times
Threads 12
Posts 43
Torque
I am fussy on posting and using NWchem.

Hi admin and everyone,

I encounter a problem with compiling NWChem with OpenIB, the error is follows:

grep: /opt/torque/lib/libtorque.la: No such file or directory
/bin/sed: can't read /opt/torque/lib/libtorque.la: No such file or directory
libtool: link: `/opt/torque/lib/libtorque.la' is not a valid libtool archive
make[5]: *** [libarmci.la] Error 1
make[5]: *** Waiting for unfinished jobs....
libtool: link: ranlib .libs/libarmcii.a
libtool: link: rm -fr .libs/libarmcii.lax
libtool: link: ( cd ".libs" && rm -f "libarmcii.la" && ln -s "../libarmcii.la" "libarmcii.la" )
make[4]: *** [all] Error 2
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [build/.libs/libga.a] Error 1
make: *** [libraries] Error 1

I don't know why compiling NWChem need libtorque.la? I don't very familiar with libtool, so I cannot find clue with this. Can anyone provide me some information on this?

The following is my environment setup:

export NWCHEM_TOP=/home/wangjb/bin/nwchem-6.1.1
export NWCHEM_TARGET=LINUX64

export ARMCI_NETWORK=OPENIB
export IB_HOME=/usr
export IB_INCLUDE=/usr/include/infiniband
export MSG_COMMS=MPI
export IB_LIB=/usr/lib64
export IB_LIB_NAME="-lrdmacm -libverbs -lrt -lnsl -lutil -ldl -lm -Wl,--export-dynamic -lrt -lnsl -lutil"

export USE_MPI=yes
export USE_MPIF=yes
export USE_MPIF4=yes
export MPI_LOC=/usr/local/openmpi
export MPI_LIB=$MPI_LOC/lib
export MPI_INCLUDE=$MPI_LOC/include

export LIBMPI="-lmpi_f90 -lmpi_f77 -lmpi -ldl -L/usr/local/intel/Compiler/11.1/038/lib/intel64 -lifport -lifcoremt -limf -lsvml -lintlc -Wl,-rpath,/usr/local/openmpi/lib -Wl,-rpath,/usr/local/intel/Compiler/11.1/038/lib/intel64"
export NWCHEM_MODULES="all"

export FC=ifort
export CC=icc

Thanks for your time.

wangjb

Clicked A Few Times
Threads 12
Posts 43
experience
only one word can be used as the title or I can not post in this forum.

Clicked A Few Times
Threads 12
Posts 43
Torque
I cannot start a new post, may be post following in here? Lucky or unlucky?

Hi admin and everyone,

I encounter a problem with compiling NWChem with OpenIB, the error is follows:

grep: /opt/torque/lib/libtorque.la: No such file or directory
/bin/sed: can't read /opt/torque/lib/libtorque.la: No such file or directory
libtool: link: `/opt/torque/lib/libtorque.la' is not a valid libtool archive
make[5]: *** [libarmci.la] Error 1
make[5]: *** Waiting for unfinished jobs....
libtool: link: ranlib .libs/libarmcii.a
libtool: link: rm -fr .libs/libarmcii.lax
libtool: link: ( cd ".libs" && rm -f "libarmcii.la" && ln -s "../libarmcii.la" "libarmcii.la" )
make[4]: *** [all] Error 2
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [build/.libs/libga.a] Error 1
make: *** [libraries] Error 1

I don't know why compiling NWChem need libtorque.la? I don't very familiar with libtool, so I cannot find clue with this. Can anyone provide me some information on this?

I add a line in order to include the libtorque.so as follows:

export LIBMPI="-lmpi_f90 -lmpi_f77 -lmpi -lopen-rte -lopen-pal -lrdmacm -libverbs -L/opt/torque/lib -ltorque -ldl -Wl, --export-dynamic -lnsl -lutil -L/usr/local/intel/Compiler/11.1/038/lib/intel64 -lifport -lifcoremt -limf -lsvml -lintlc -Wl,-rpath,/usr/local/openmpi/lib -Wl,-rpath,/usr/local/intel/Compiler/11.1/038/lib/intel64"

But NWchem always want to find libtorque.la. How to solve this problem. Any advice is appreciated.

Thanks for your time.

wangjb


Forum >> NWChem's corner >> Compiling NWChem



Who's here now Members 0 Guests 1 Bots/Crawler 0


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC