ECCE Not Running Properly

From NWChem

Viewed 3218 times, With a total of 5 Posts
Jump to: navigation, search

Clicked A Few Times
Threads 2
Posts 5
I recently installed ECCE onto a linux box running 64-bit Fedora 18.
WHen I tried to run ECCE I get the error message:
Failed to load module: /usr/lib64/gio/modules/libgiolibproxy.so
However, the logon screen pops up and I can gain access to the ECCE menu bar.

I receive core dumps in addition to the failure to load message for everything but the periodic table. In that instance I still get the warning message but the periodic table does pop up.

I could only find one reference to this library when searching posts - the recommendation was for a UBUNTU box and to remove the appmenu-gtk package. I use yum, so the yum remove command came back that this package was not installed.

The only thing I can add to this is that there are no rpms for gtk+-2.0. I have gtk+ v1.2.x. I suppose this might be the root cause, but without access to a 2.0 version of gtk+, it seems I am dead in the water.

Gets Around
Threads 2
Posts 82
I'd recommend building ECCE from source code. It's really not that hard, but of course you'll need the right underlying packages first. I believe the package name for Fedora is gtk2-devel and not gtk+-2.0. If you download a source code distribution, look at the README file in the build subdirectory after you extract the distribution. Those are the instructions for building ECCE from source code. If you search for Fedora in that file you'll see that it was the one platform where ECCE wouldn't build properly. But that was for Fedora 16 and maybe that problem has been resolved. It actually wasn't an ECCE build problem, but a problem with installing the gtk2 development package. If that can't be done successfully then there is no way to build ECCE, nor run it from a binary distribution. ECCE is definitely dependent on the more recent GTK 2.0 (which is many years old) because that's what the wxWidgets C++ GUI library ECCE uses for all applications needs. So you can't get away with running an older GTK 1.2 with ECCE. I'm definitely interested in whether you can get it to work on Fedora so I can update the documentation, but we don't have funding to get it to work for you. When ECCE was released as open source this past fall, Fedora unfortunately was the one version of Linux where it wasn't building.

If you really want to try further with the ECCE binary distribution it does seem like the crux of your issue is installing the gtk2 package as well. It shouldn't need to be the development version for the binary distribution, but you will need to find/install the right runtime gtk2 package before you'd be able to run ECCE. It's certainly possible/likely that the ECCE check for gtk+-2.0 in the install script isn't right on all platforms so I wouldn't put too much stock in that. The fallback of course for not being able to install the a gtk2 package is to build gtk2 itself from source code. Another approach depending upon where you are in your evaluation/use of ECCE is to install VirtualBox on your Fedora machine and then install another Linux (I recommend Debian) within that where you would install and run ECCE.

-Gary

Clicked A Few Times
Threads 2
Posts 5
Solution?
Gary, I tried to run the ECCE build but the final build - construction of ECCE from the 3rdparty software failed. All the other "widgets" compiled correctly. I noted this in my other posting. I tried to copy over the entire httpd directory and use that to start the ECCE web server - but that ran into problems... I documented them but cannot put them in an email as the WIki forbids me from posting that info - odd, but after 12 tries it seems one is insane to try again.

Anyway - a little understanding of the issues within the final make file would go a long way. Fedora17 seems far more stable than anything you observed in the previous release.

Gets Around
Threads 2
Posts 82
Fedora 18 ECCE installation
Hello Mark,

I was able to take a look at installing ECCE under Fedora 18. First, definitely Fedora requires extra work not needed with other Linux versions like Debian and Mint--I'd never recommend Fedora for use with ECCE or otherwise if a choice can possibly be made because I don't find it to be nearly as nice of a user or developer environment in general. It was quite a painful process to get ECCE functional because of missing packages in the Fedora 18 distribution. But, I was able to figure out what packages needed to be installed and got an ECCE binary distribution to run. So, I'd give up on building from source code because that will require even more developer type packages to be installed like the gtk2 ones mentioned previously. I'd also make sure to use Fedora 18 rather than 17 just because I don't have the time to work through the issues on an non-current Linux and given what I found with Fedora 18, I'm sure there would be some Fedora 17 specific issues as well. Hopefully you can just follow what I did and it will work for you. This was a brand new Fedora 18 virtual machine I created so there shouldn't be anything magic with the steps I list here:

1. Download a new ECCE 6.4 64-bit binary distribution. I did have to fix a small bug related to creating thumbnail builder images displayed on the main Calculation Editor window and this fix is in the latest downloads dated March 14, 2013.

2. From a root shell you'll need to "yum install" a few packages before you try installing ECCE. The commands are:
 a.  yum install tcsh
b. yum install ImageMagick
c. yum install xterm
d. yum install perl
e. yum install cpan
f. yum install perl-CPAN

3. Unfortunately the version of perl with Fedora 18 is newer and deprecates some libraries needed for ECCE. This means you need to use cpan to get back these libraries. Without them you'll never be able to create an input file for instance to run an NWChem job and I'm sure that's one of many issues you'd have. I also really struggled with getting cpan not to error out when trying to install these added libraries. Maybe it was just a flaky internet connection between my VM and the CPAN servers, but it wouldn't work at all the first afternoon and then finally worked the next morning. Here's how I got it to work so I'd recommend following this:

Enter the "cpan" command (in a root shell just like the yum install commands) which gives you a cpan command prompt. The first time you do this it may ask you some questions to let it configure cpan. I told it to automatically configure. The one question where I didn't just take the default was when it asked how to get root access. For this I replied "manual" (sudo was another choice at this prompt) because I was running cpan in a root shell already so it shouldn't need to do anything. When the configuration step is done here is the command you need to enter at the cpan prompt: install Perl4::CoreLibs

This told me it had to first install something named ModuleLib or something like that so I let it do that and then it installed CoreLibs, which are the extra libraries needed by ECCE. Pay attention to whether it said there were problems or not with installing the CoreLibs since a failure means you'll have problems down the road running ECCE so somehow you have to get this working. This was the only real tricky and frustrating part about getting ECCE to work on Fedora 18 other than the general lack of packages that most other Linux versions have standard (I don't like the whole look and feel of the standard Fedora window manager either, but that's a different topic).

4. Install the ECCE binary distribution as you would normally do. You don't need to be in a root shell to do this and I wouldn't recommend it unless you are installing ECCE for multiple users and not just yourself.

5. Follow the instructions at the end of the install for sourcing the runtime_setup script and starting the ECCE server.

6. Start the ECCE client GUI with the "ecce" command.

7. I was able to step through the ECCE gateway, organizer, calculation editor, builder, basis set tool, launcher, and calculation viewer to setup and run a simple NWChem calculation--meaning I also ran the NWChem distribution bundled with ECCE.

I didn't exhaustively test ECCE, but that's a lot further than you apparently got. Hopefully this helps. As I mentioned before we don't have the funding to work through issues like this explaining why it's taken a month for me to provide any kind of response. For really simple issues I try to respond in a week or two.

Best regards,
Gary

Gets Around
Threads 16
Posts 115
Gary,
I've posted a possible fix in the 'problems with httpd' thread. Basically it boils down to replacing
require "getopts.pl";

with
use Getopt::Std

and making sure that all instances of getops are lower case.

I just noticed that it's basically the same solution that this post suggests:
[1]
+-require 'getopts.pl';
++use Getopt::Std;

/Andy
Edited On 2:01:13 PM PDT - Sun, Mar 24th 2013 by Ohlincha

Gets Around
Threads 2
Posts 82
Thanks Andy. I have updated to the new Getopts format. See my reply to the other thread for details.

Gary


Forum >> ECCE: Extensible Computational Chemistry Environment >> General ECCE Topics



Who's here now Members 0 Guests 1 Bots/Crawler 0


AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC