Problems compiling

From NWChem

Viewed 198 times, With a total of 2 Posts
Jump to: navigation, search

Just Got Here
Threads 1
Posts 2
I've been trying to read through other posts on this forum (and around the web) to get NWChem compiling, but unfortunately I'm still having problems and I'm hoping that someone can identify the problem.

I tried putting all of the environment set up and install instructions into a script which I've pasted just below:
  1. /bin/bash

export TCGRSH=/usr/bin/ssh
export NWCHEM_TOP=`pwd`
export USE_MPI=y
export USE_MPIF=y
export USE_MPI4=y
export MPI_LOC=/usr/local
export MPI_LIB=$MPI_LOC/lib
export MPI_INCLUDE=$MPI_LOC/include
  1. export LIBRARY_PATH=$LIBRARY_PATH:/usr/lib/openmpi/lib
export LIBMPI="-lmpi_f90 -lmpi_f77 -lmpi -ldl -Wl,--export-dynamic -lnsl -lutil"
export BLASOPT="-L/opt/acml5.3.1/gfortran64_int64/lib -lacml"

cd $NWCHEM_TOP/src

make clean
make nwchem_config
make FC=gfortran

At one point I ran into a problem which (at least for another user on this forum) required obtaining and applying the "Parallelmpi.patch" - which I believe I did successfully since the compilation runs longer before producing another, different error. The last few lines of the output are below:


Got lock on /home/evan/nwchem-6.5/lib/LINUX64/libccca.lock
ar r /home/evan/nwchem-6.5/lib/LINUX64/libccca.a task_ccca.o ccca_utils.o
ar: creating /home/evan/nwchem-6.5/lib/LINUX64/libccca.a
echo /home/evan/nwchem-6.5/lib/LINUX64/libccca.a
make nwchem.o stubs.o
gfortran -m64 -ffast-math -Warray-bounds -fdefault-integer-8 -O2 -g -fno-aggressive-loop-optimizations -g -O -I. -I/home/evan/nwchem-6.5/src/include -I/home/evan/nwchem-6.5/src/tools/install/include -DGFORTRAN -DCHKUNDFLW -DGCC4 -DGCC46 -DEXT_INT -DLINUX -DLINUX64 -DPARALLEL_DIAG -DCOMPILATION_DATE="'`date +%a_%b_%d_%H:%M:%S_%Y`'" -DCOMPILATION_DIR="'/home/evan/nwchem-6.5'" -DNWCHEM_BRANCH="'6.5'" -c -o nwchem.o nwchem.F
gfortran -m64 -ffast-math -Warray-bounds -fdefault-integer-8 -O2 -g -fno-aggressive-loop-optimizations -g -O -I. -I/home/evan/nwchem-6.5/src/include -I/home/evan/nwchem-6.5/src/tools/install/include -DGFORTRAN -DCHKUNDFLW -DGCC4 -DGCC46 -DEXT_INT -DLINUX -DLINUX64 -DPARALLEL_DIAG -DCOMPILATION_DATE="'`date +%a_%b_%d_%H:%M:%S_%Y`'" -DCOMPILATION_DIR="'/home/evan/nwchem-6.5'" -DNWCHEM_BRANCH="'6.5'" -c -o stubs.o stubs.F
gfortran -L/home/evan/nwchem-6.5/lib/LINUX64 -L/home/evan/nwchem-6.5/src/tools/install/lib -o /home/evan/nwchem-6.5/bin/LINUX64/nwchem nwchem.o stubs.o -lnwctask -lccsd -lmcscf -lselci -lmp2 -lmoints -lstepper -ldriver -loptim -lnwdft -lgradients -lcphf -lesp -lddscf -ldangchang -lguess -lhessian -lvib -lnwcutil -lrimp2 -lproperty -lsolvation -lnwints -lprepar -lnwmd -lnwpw -lofpw -lpaw -lpspw -lband -lnwpwlib -lnwxc -lcafe -lspace -lanalyze -lqhop -lpfft -ldplot -ldrdy -lvscf -lqmmm -lqmd -letrans -lpspw -ltce -lbq -lcons -lperfm -ldntmc -lccca -lnwcutil -lga -larmci -lpeigs -lperfm -lcons -lbq -lnwcutil -L/opt/acml5.3.1/gfortran64_int64/lib -lacml -llapack -lblas -L/usr/local/lib -lmpi_f90 -lmpi_f77 -lmpi -ldl -Wl,--export-dynamic -lnsl -lutil -libverbs
/usr/bin/ld: Warning: alignment 16 of symbol `cface_' in /home/evan/nwchem-6.5/lib/LINUX64/libstepper.a(stpr_face.o) is smaller than 32 in /home/evan/nwchem-6.5/lib/LINUX64/libstepper.a(stpr_partit.o)
/usr/bin/ld: /home/evan/nwchem-6.5/src/tools/install/lib/libarmci.a(cbuf.o): undefined reference to symbol 'pthread_spin_init@@GLIBC_2.2.5'
/lib/x86_64-linux-gnu/ error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
GNUmakefile:41: recipe for target 'all' failed
make: *** [all] Error 1

Other notes:
-I believe I have OpenMPI and ACML installed correctly and tried to use settings for each of them
-At the moment, my settings for MPI_LIB, MPI_INCLUDE, and LIB_MPI are taken directly from the webpage with instructions on compiling NWChem from this website (, however when I run the tool provided with the distribution the following definitions are given:

export MPI_INCLUDE="-I/usr/local/include -I/usr/local/lib"
export MPI_LIB="-L/usr/local/lib"
export LIBMPI="-lmpi_usempif08 -lmpi_usempi_ignore_tkr -lmpi_mpifh -lmpi"

However, either configuration generates the failure described above. Any help would be very much appreciated.

Forum Vet
Threads 4
Posts 936
You need -lpthread in your linking stage
Please set
export LIBMPI="-lmpi_usempif08 -lmpi_usempi_ignore_tkr -lmpi_mpifh -lmpi -lpthread"

Just Got Here
Threads 1
Posts 2
Thanks a lot!

That seems like it took care of my problems- I can generate an executable that is capable of running the examples that are provided.

Thanks again

Forum >> NWChem's corner >> Compiling NWChem

Who's here now Members 0 Guests 1 Bots/Crawler 0

AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC