nwchem-6.6/src/config/nwchem config.h: No such file or directory

From NWChem

Viewed 1748 times, With a total of 0 Posts
Jump to: navigation, search

Just Got Here
Threads 1
Posts 1
I downloaded the 6.6 source from the download page, and all of its patches.

Applied all patches without issue. I moved on to setting up my environment for compilation.

Following along with the instructions provided by nwchem, it seems like I may need to do the 64_to_32 subsection of Optimized Math Libraries. When I try the very first step, 'make clean' I get:

nwchem-6.6/src/config/nwchem_config.h: No such file or directory

I'm now going off-course from the instructions and am wandering through the files&folders looking for a clue...
I looked for the file myself, sure enough, it doesn't exist. I noticed a "HOW_TO_CONFIGURE" file in the directory where the nwchem_config.h should have been. I'm having a real hard time making sense of it. It immediately mentions repositories, which I didn't use to get the code, since I downloaded it from the download button on the download page so I'm less certain of how relevant these instructions may or may not be to me.

I've just now noticed (by skipping ahead in the instructions) that after the point where this file is required, the user is instructed to build it. This is confusing...but I tried to follow those instructions anyway since they look helpful, here's the sections straight from the compiling guide::

Building the NWChem binary

Once all required and optional environment variables have been set, NWChem can be compiled:

 % cd $NWCHEM_TOP/src

 % make nwchem_config

 % make >& make.log

When I do 'make nwchem_config' I get the exact same error, amazingly enough, it looks like the tool - in order to build the file in question - requires that the file it's supposed to build already exists! Here's the error, again (I've edited out my working directory, but you get the idea):

nwchem-6.6/src :: make nwchem_config
config/makefile.h:141: nwchem-6.6/src/config/nwchem_config.h: No such file or directory

  Is this normal?  What SHOULD I be doing?

Thanks for your help.


Further down the rabbit hole... A coworker of mine found that doing:

make FC=ftn CC=cc nwchem_config NWCHEM_MODULES=all

yields the nwchem_config.h file, where as purely following the instructions does not. It looks like there is no error-case in the Makefile where the nwchem_config.h does not already exist for writing data into. Is anyone else running into this? As a seasoned veteran of build-from-source linux distros, this config process seems broken.
Edited On 12:39:28 PM PST - Mon, Mar 7th 2016 by Andrew.downs

Forum >> NWChem's corner >> Compiling NWChem

Who's here now Members 0 Guests 1 Bots/Crawler 0

AWC's: 2.5.10 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC